Do not input private or sensitive data. View Qlik Privacy & Cookie Policy.
Skip to main content

Announcements
ALERT: QlikView server communication interruptions following Microsoft Windows Domain Controller security updates

Qlik Sense Enterprise on Windows: Rim node registration or connection fails: cannot reach host

100% helpful (2/2)
cancel
Showing results for 
Search instead for 
Did you mean: 
Yoichi_Hirotake
Former Employee
Former Employee

Qlik Sense Enterprise on Windows: Rim node registration or connection fails: cannot reach host

Last Update:

Aug 11, 2026 2:31:17 AM

Updated By:

Sonja_Bauernfeind

Created date:

Sep 8, 2016 11:45:36 PM

Registering or re-registering a Rim node in Qlik Sense Enterprise on Windows fails with:

Cannot reach the following remote host when distributing certificates: http://nodename:4444/setup/certificateDistribution
 
1714615.png

 

 

 

 

 

 

 

 

Environment

  • Qlik Sense Enterprise February 2019 and later

 

Cause

  • If the TCP port 4444 is not blocked in the environment between the Central and Rim nodes, the Node registration error Cannot reach the following remote host when distributing certificates will also pop up when re-registering the RIM node if uninstall/reinstall of the Qlik Sense server was not performed using a local Administrator account on the Rim node.
  • Mismatched Qlik Sense version on Central node and Rim node. The Central node would not distribute the certificate because the Central node had been patched and the Rim node had not been patched to the same level. 

Resolution

  1. Make sure Central and Rim nodes have been patched to the same level.
  2. See related article Qlik Sense - Node is offline - Failed to retrieve service status from 'http://Servername:4444/status...
  3. See related article Rim node offline in QMC, bootstrap shows "Waiting for initial configuration to be run by node"
  4. To be able to re-register a deleted RIM node, it is necessary to uninstall Qlik Sense on the Rim node and reinstall it before the node re-registration.

The "Remove Qlik Sense certificates and data folders" option should be selected when uninstalling the Qlik Sense Enterprise Server. See Deleting Nodes as the reference. 

Notes:

  • The Qlik Sense service account needs to be a member of the Administrator group on the RIM node when the re-distribution of the certificate is performed. Certificate distribution to Rim nodes is considered a deployment (installation) task. As such, administrative privileges are needed.
  • If the service account is found without administrative local rights (added to the local administrators group on the server), then add it, restart the services, and try again.
  • If this cannot be achieved in the environment, please review the information under Using an account without administrator privileges to run the Qlik Sense services during the installa...
Labels (2)
Comments
SwapneelGolapkar
Contributor III
Contributor III

We faced similar issue, thanks to this article we were able to fix it by installing the patch on the rim node.

Only downside / feedback to Qlik would be - it would be great if the patch version is clearly visible in the Control Panel.

 

Thanks,

Swapneel

Sonja_Bauernfeind
Digital Support
Digital Support

Thank you for the feedback,  @SwapneelGolapkar!

Version history
Last update:
‎2026-08-11 02:31 AM
Updated by: