Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

ODBC User Directory Connectors

Our primary data store is a Microsoft SQL Server Database. We've recently upgraded from SQL Server 2016 to SQL Server 2017 and we're having trouble linking Qlik Sense to the database.

We have Qlik Sense (version 2.2 I think - where can I check this?) running on Windows Server 2012 R2. We store the database connection details in Windows' ODBC Data Sources on that server. I've updated the connection to point to the new database and Qlik is happy with this: the Reload task runs successfully.

However, the User Directory Connector is less happy. It says:

The User Directory Connector (UDC) is not configured, because the following error occurred: Error when validating tables: One or more of the expected tables QlikUser and QlikUserAttribute are not present

Our settings look like this:

ODBC UDC.png

I am confident that the Connection String is correct, for the following reasons:

  • The main data load task uses the same connection (iPresentStaging, as defined in Windows' ODBC Data Sources), and this runs successfully.
  • If I change the password in the Connection String, I get a different error ("Exception when trying to connect to the data source. Edit the connection string in the user directory connector configuration").
  • I also get that different error if I change the user's password in the SQL database.

QlikUser and QlikUserAttribute are Views in our database. They are operating normally (I can SELECT from them). They have no unusual permissions on them, so the database user called "Qlik" should be able to access them. Since it can do the main data load task, I don't think that's the issue. I've tried explicitly granting the database user access to them anyway, but that made no difference.

I have tried making actual tables (rather than views) in our database, pointing the UDC at them. I still get the same error.

I have restarted all the Qlik services to no avail.

Are we aware of any changes between SQL Server 2016 and 2017 that might cause this issue? Is there anything more I can try to resolve this?

Thanks.

1 Solution

Accepted Solutions
ogster1974
Partner - Master II
Partner - Master II

Try using the SQL (via ODBC) connection type.  Perhaps you need to upgrade the driver but like you say it works through your reload of apps.

Im not using that version of SQL so cannot confirm your issue is related.  you will find your Qlik Sense version number in the bottom right hand corner of your screen.

Perhaps try renaming your view to try and force a different error to help trouble shoot it.

Regards

Andy

View solution in original post

6 Replies
ogster1974
Partner - Master II
Partner - Master II

Try using the SQL (via ODBC) connection type.  Perhaps you need to upgrade the driver but like you say it works through your reload of apps.

Im not using that version of SQL so cannot confirm your issue is related.  you will find your Qlik Sense version number in the bottom right hand corner of your screen.

Perhaps try renaming your view to try and force a different error to help trouble shoot it.

Regards

Andy

ogster1974
Partner - Master II
Partner - Master II

what we use to do our UDC via SQL

Emmanuelle__Bustos
Partner - Specialist
Partner - Specialist

Have you tried for the tables put first the owner ie. ownername.qlikuser and ownername.qlikuserAttribute??

Anonymous
Not applicable
Author

This didn't work, sorry.

Thanks.

Anonymous
Not applicable
Author

Excellent! That worked perfectly. Thank you!

Anonymous
Not applicable
Author

Hi

     I have  this issue too,my visible connection string is “Driver={Oracle in instantclient_12_1};dbq=isae;uid=metadb_selfwjl;pwd=Universe_123”,and it says

The User Directory Connector (UDC) is not configured, because the following error occurred: Error when validating tables: One or more of the expected tables QlikUser and QlikUser_Attr are not present。

     could you please tell me how did you solve it。

Thanks。