Skip to main content
Announcements
July 15, NEW Customer Portal: Initial launch will improve how you submit Support Cases. IMPORTANT DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
mstoler
Partner - Specialist
Partner - Specialist

upgrading Qlik Sense from Nov 2020 with Postgre sql 9.6

Hello,

I am upgrading an on-premise from Qlik Sense Nov 2020 with Postgresql 9.6 to Qlik Sense Aug 2023. 

I was going to upgrade Postgre sql first but the Postgre installer gave me an error.

Can I upgrade to Qlik Sense Aug 2023 and then upgrade to Postgresql?

Thank You,

Michael

 

Labels (1)
1 Solution

Accepted Solutions
John_Sathya
Support
Support

Hi @mstoler ,

Qlik Sense August 2023 requirements starts from Postgres 11.X. Please see : System requirements for Qlik Sense Enterprise | Qlik Sense for administrators Help

You need to upgrade the Database first. 
Please reach out to Support if you have issues with Postgres upgrade. The QPI tool will help you upgrade the Database but if you want bundled Postgres then take a backup of the postgres Database, unistall Qlik Sense, Install a fres Qlik Sense August version and restore the Database.

The other option would be to use the QPI tool to upgrade the Database : Upgrading and unbundling the Qlik Sense Repository... - Qlik Community - 1934238

Also see : Installing or upgrading PostgreSQL using the Qlik PostgreSQL Installer | Qlik Sense for administrato...

Thanks.




View solution in original post

3 Replies
mstoler
Partner - Specialist
Partner - Specialist
Author

It looks like the Aug 2023 upgrade will not run. 

Do I need to upgrade to Feb 2022 first, then upgrade Postgresql and then upgrade to Aug 2023?

Thank You,

Michael

 

John_Sathya
Support
Support

Hi @mstoler ,

Qlik Sense August 2023 requirements starts from Postgres 11.X. Please see : System requirements for Qlik Sense Enterprise | Qlik Sense for administrators Help

You need to upgrade the Database first. 
Please reach out to Support if you have issues with Postgres upgrade. The QPI tool will help you upgrade the Database but if you want bundled Postgres then take a backup of the postgres Database, unistall Qlik Sense, Install a fres Qlik Sense August version and restore the Database.

The other option would be to use the QPI tool to upgrade the Database : Upgrading and unbundling the Qlik Sense Repository... - Qlik Community - 1934238

Also see : Installing or upgrading PostgreSQL using the Qlik PostgreSQL Installer | Qlik Sense for administrato...

Thanks.




mstoler
Partner - Specialist
Partner - Specialist
Author

Hello,

It looks like I am in between Nov 2020 and Aug 2023.

I started the upgrade from Nov 2020 to Aug 2023. 

However, the Aug 2023 upgrade stopped and indicated Postgresql is not compatible.

What I did was uninstall Aug 2023, upgrade to Feb 2022, install the Postgresql upgrade (worked fine), and then upgrade to Aug 2023. 

Thanks,