Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
dberkesacn
Partner - Creator III
Partner - Creator III

Calculated Dimension No Gray Record Visible

Hi All,

 

when I create a calculated dimension like ==> aggr(only({<myFavouriteCountry={'India'}>}City),City) and make a selection I dont see the gray options in the filter pane (where I made the selection), only the selected ones (with green...)

I would like to have this feature using front end expression, not backend script.

Thanks,

Dan

 

1 Solution

Accepted Solutions
dberkesacn
Partner - Creator III
Partner - Creator III
Author

with if() after selection, qlik displays in the selection ribbon myFavouriteCountry = India and the selected City as well.

having set analysis aggr() only()  combo worked if the identifier is 1.

aggr(only({1<myFavouriteCountry={'India'}>}City),City)

 

Dan

View solution in original post

4 Replies
JordyWegman
Partner - Master
Partner - Master

Hi Dan,

What is the outcome, only the cities in India?

I think you don't see the gray options because your set analysis is forcing this.

Jordy

Climber

Work smarter, not harder
dberkesacn
Partner - Creator III
Partner - Creator III
Author

that is my problem.

I wanna create a new dimension using only front-end expression which will shows gray values after selection.

D

tresesco
MVP
MVP

Try using IF instead of aggr and only(). Try like:

If(myFavouriteCountry='India', City)

 

Assuming myFavouriteCountry is a field.

dberkesacn
Partner - Creator III
Partner - Creator III
Author

with if() after selection, qlik displays in the selection ribbon myFavouriteCountry = India and the selected City as well.

having set analysis aggr() only()  combo worked if the identifier is 1.

aggr(only({1<myFavouriteCountry={'India'}>}City),City)

 

Dan