Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Tell us which business and trade publications you read most regularly: RESPOND NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
reivax31
Partner - Creator III
Partner - Creator III

Delimiter

Hi Qlikers,

I'm trying to load a CSV file in Qlik Sense. But the delimiter does not work properly. Each dimension is separated by "," like: Country","City","Address (so delimiter in CSV is: double quote AND comma AND double quote)

In Address I can have comma sometimes in between the value. This will shift the rest of the address after the comma in the following column.

I tryed: delimiter is '","' (quote AND double quote  AND comma  AND double quote AND quote). This doesn't work. It will still split my data for each comma and now also for each double quote. because I can have " (double quote) in my address also.

So is there a way to tell Qlik that I really want to do the split for each group of  "," that I have in my data? And not for each single comma or single double quote that I can have in my Address.

The scrip used:

LOAD

[@1]  AS [Country],

...

FROM [lib://Export/TEST.csv]

(txt, utf8, no labels, delimiter is ',', no eof);

Thanks for your help

1 Solution

Accepted Solutions
reivax31
Partner - Creator III
Partner - Creator III
Author

Hi Marcus,

It didn't work with msq. But I found a way around by:

-Load without delimiter

-Replace "," by ~

-Store as CSV

-Load with delimiter ~

View solution in original post

2 Replies
marcus_sommer
MVP & Luminary
MVP & Luminary

Have a look for the msq-options within the file-format, like: (txt, utf8, no labels, delimiter is ',', no eof, msq)

- Marcus

reivax31
Partner - Creator III
Partner - Creator III
Author

Hi Marcus,

It didn't work with msq. But I found a way around by:

-Load without delimiter

-Replace "," by ~

-Store as CSV

-Load with delimiter ~