Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
ismailk94
Contributor II
Contributor II

Retrieve automation usage for tenant

Hi Qlik Community!

I am trying to use the "Get/v1/automations/usage"-API which is described on 
https://qlik.dev/apis/rest/automations#%23%2Fentries%2Fv1%2Fautomations%2Fusage-get

As you can see in the documentation the response should be like this:

ismailk94_0-1677855607209.png


When I send the API call I have defined both the URL, Bearer Authorization and the filter-parameter as:
filter=date gt "2023-03-02"

My response only contains the first three items: date, name and value.
I need the rest of the response from the picture: Automation: guid, name and ownerId.

What am I missing?

Sincerely, 
Ismail

Labels (3)
1 Solution

Accepted Solutions
AfeefaTk
Support
Support

Hi @ismailk94 

Could you please try adding breakdownBy=automation to your query parameters?

This seems to work for me

retrieve-automation-usage.png

Thanks

View solution in original post

4 Replies
Shai_E
Support
Support

Hi Ismail,

Did you try adding the query parameter "breakdown"?

ismailk94
Contributor II
Contributor II
Author

Hi Shai_E

Thanks for the reply. 
I have tried to add the breakdown-parameter in several ways but I keep getting an error - do you know the syntax of how the breakdown-parameter should be added?

 

Ismail

AfeefaTk
Support
Support

Hi @ismailk94 

Could you please try adding breakdownBy=automation to your query parameters?

This seems to work for me

retrieve-automation-usage.png

Thanks

ismailk94
Contributor II
Contributor II
Author

Hi AfeefaTk

Works perfect! Thanks 🙂

Ismail