Qlik Community

Qlik Compose for Data Warehouses

Discussion board for collaboration on Qlik Compose for Data Warehouses.

Announcements
June 28, 10AM ET: Qlik Nation and Qlik Community present: CyberSleuth REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
dpurdy66
Contributor III
Contributor III

Dropping Error Marts takes a long time when resetting a project.

Since updating to the August release of Compose for DW, the "dropping error marts" operation takes a long time to complete when resetting a project.    In my case, there aren't even any error mart tables to drop...   

Has anyone else seen this behavior?  Is it a bug?

Our target is SLQ Server and a SQL Profiler trace shows that compose is running the same two queries over and over:

SELECT
SCHEMA_NAME (uid) AS ownerName
,name AS tableName
FROM
sysobjects WITH (NOLOCK)
WHERE
type = N'U' AND (category = 0 OR category = 32) AND OBJECTPROPERTY (id, 'IsSystemTable') = 0 AND name <> N'sysdiagrams' AND SCHEMA_NAME (uid) = 'EM';

EXEC sp_executesql
N'select TABLE_CATALOG, TABLE_SCHEMA, TABLE_NAME, CHECK_OPTION, IS_UPDATABLE from INFORMATION_SCHEMA.VIEWS where (TABLE_CATALOG = @Catalog or (@Catalog is null)) and (TABLE_SCHEMA = @Owner or (@Owner is null)) and (TABLE_NAME = @Table or (@Table is null)) order by TABLE_CATALOG, TABLE_SCHEMA, TABLE_NAME'
,N'@Catalog nvarchar(4000),@Owner nvarchar(2),@Table nvarchar(4000)'
,@Catalog = NULL
,@Owner = N'EM'
,@Table = NULL;

Labels (1)
2 Solutions

Accepted Solutions
Adam_Herman
Support
Support

Hi @dpurdy66 ,

Are you still facing this issue? 

If you do, then kindly raise an incident for the same to the Support team, as this issue should be investigated further, and Compose behavior should be analyzed as well.

Regards,

Adam

View solution in original post

dpurdy66
Contributor III
Contributor III
Author

I seems to have gotten better.  I will create a ticket if it happens again.  Thanks for following up!

View solution in original post

3 Replies
Adam_Herman
Support
Support

Hi @dpurdy66 ,

Are you still facing this issue? 

If you do, then kindly raise an incident for the same to the Support team, as this issue should be investigated further, and Compose behavior should be analyzed as well.

Regards,

Adam

dpurdy66
Contributor III
Contributor III
Author

I seems to have gotten better.  I will create a ticket if it happens again.  Thanks for following up!

Adam_Herman
Support
Support

It's always our pleasure. 

Yes please, do not hesitate to contact us for any other queries you might have.

Cheers,
Adam