Skip to main content
Applications are open for the 2024 Qlik Luminary Program. Apply by December 15 here.
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

WAL reader terminated with unrecognized error.

Hi Team,


I tried upgrading one of my replicate server from 6.6 to 7.0 to mitigate the Log4j vulnerability, where the source is (Amazon RDS for PostgreSQL).

So after upgrading the server to 7.0 I tried resuming the jobs but I'm getting the below mentioned error:

"WAL reader terminated with unrecognized error.
The LSN 00000003/46B18088 doesn't exist in the provided slot"

Please help me to overcome this error and resume the jobs successfully.


Thanks and Regards,

Antony S

Labels (2)
1 Reply
Specialist II
Specialist II

How much time elapsed while the Replicate tasks were down for server upgrade?

Could it be that the required wall files are no longer available on the source?

Did you try starting by timestamp? That would confirm.

Now, I would hope/expect this major upgrade is just done on a  development or QA server, not in prod right?

For the time being you may look at alternative means to handle the (perceived?) Log4j vulnerability. I just disabled the endpoint server in the service configuration file [windows: C:\Program Files\Attunity\Replicate\bin\repctl.cfg ]  and removed the module.  The Replicate server is likely  in a private domain, and the log4j vulnerability is possibly extremely hard or impossible to exploit, but I supposed that will not satisfy the auditors right?