Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

martinmichalski
New Contributor II

App keeps getting corrupted

Hello Community,

I am facing a really annoying issue with an app in Qlik Sense. Since 2 weeks ago it has already got corrupted 4 times, giving me no other option than deleting and republishing it again.

This is very frustrating as the app is displayed on static screens and each time we republish, all the links (more than 20 pages) need to be changed.

We have received two different kind of error messages when the app got corrupted: one directly saying that the app is corrupted and the other one saying "the object could not be found".

I don't really think this has something to do with the App itself but has relation some weird infrastructure issue. Have you experienced something like this before? Do you have any advice to avoid or reduce the risk of an app getting corrupted?

I would really appreciate your help.

Thanks in advance,

Martin

8 Replies
rodrigoteixeira
New Contributor

Re: App keeps getting corrupted

Hi Martin,

Yes, we are having exactly the same issues. A lot of instability.

Apps getting corrupted, not allowing a simple Change of ownership or even a simple publish into a stream.

We need to keep exporting Apps as to not lose data and the system is very unstable. Totally frustrating.

Re: App keeps getting corrupted

If when you publish the app you choose to replace the existing app then any url links to it should remain the same which will make it less painful for you.

For the actual corruptions, have you contacted Qlik Support ?

Are you running a multi node cluster ?

martinmichalski
New Contributor II

Re: App keeps getting corrupted

We found that most of the times the corruption was related with lack of RAM memory on the server. When this app was being reloaded and the server crashed, it used to get corrupted. Increasing the memory helped a lot.

On the other hand, when the app gets corrupted it doesn't let me to replace it by a different one, the only thing I can do is delete it and publish a new one.

Best regards

rodrigoteixeira
New Contributor

Re: App keeps getting corrupted

Yes, we have contacted Qlik Support but not yet a definite and clear answer.

Yes, we are using Multi-node. Is this solvable if we have only one node?

By looking at our memory usage, it looks that sometimes it reaches 80% or 90% of usage. Should this be a red alert as to increase memory?

rodrigoteixeira
New Contributor

Re: App keeps getting corrupted

Thanks Martin. Yes, our memory usage sometimes peaks to 80, 90% usage.

How did you reach the conclusion that it was a memory topic?

And since you increased memory did your problems go away or did it only decrease?

Thanks.

martinmichalski
New Contributor II

Re: App keeps getting corrupted

Yes, after increasing the RAM in the server our app stopped getting corrupted.

Qlik Sense Engine used to crash as well when this happened. By comparing the logs from the engine crash and a memory dump we found correlation. However, only those apps who were being reloaded (or maybe saved) during the crash used to get corrupted. This particular app gets reloaded every 15 minutes, so it had a bigger chance of getting corrupted than others.

rodrigoteixeira
New Contributor

Re: App keeps getting corrupted

Martin,

Thank you so much for the feedback. I will inform my IT colleagues of the correlation.

Thanks again.

Re: App keeps getting corrupted

Could be worthwhile asking Qlik Support re your symptoms and multi vs single node.  I not knowledgeable in this field, but it somehow rings a bell to me.

Community Browser