Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

paulyeo11
Valued Contributor II

Qlik Sense how to disable sort feature on straight table ?

Hi All

May i know how to prevent user from click on the table first row field to sort ?

My this table if some one click the sort by sales  or Opportunity or Assigned to field , the table will display the wrong result.

Paul

1 Solution

Accepted Solutions

Re: Qlik Sense how to disable sort feature on straight table ?

I don't think there is a setting to turn off interactive sort, but there is a bit of a trick you can apply.  If you use any of the inter-row functions -- such as Above(), interactive sorting in a table is disabled.  So wrap one of your measures in Above() with an offset of 0.  For example, assume your Measure is "sum(Sales)".  Change this to:

Above(Sum(Sales),0)

You will get the same results but interactive sort will be disabled.  This will mess with the total values though so you may have to change the total mode to Sum.

-Rob

http://masterssummit.com

http://qlikviewcookbook.com

4 Replies
Digvijay_Singh
Honored Contributor III

Re: Qlik Sense how to disable sort feature on straight table ?

You may need to disable interactive sort in below sort view -

Capture.PNG

paulyeo11
Valued Contributor II

Re: Qlik Sense how to disable sort feature on straight table ?

Hi Dig

I refer to Qlik Sense , you send me the one is for Qlik View

Paul

Digvijay_Singh
Honored Contributor III

Re: Qlik Sense how to disable sort feature on straight table ?

My bad! I think not possible in Qlik Sense.

Re: Qlik Sense how to disable sort feature on straight table ?

I don't think there is a setting to turn off interactive sort, but there is a bit of a trick you can apply.  If you use any of the inter-row functions -- such as Above(), interactive sorting in a table is disabled.  So wrap one of your measures in Above() with an offset of 0.  For example, assume your Measure is "sum(Sales)".  Change this to:

Above(Sum(Sales),0)

You will get the same results but interactive sort will be disabled.  This will mess with the total values though so you may have to change the total mode to Sum.

-Rob

http://masterssummit.com

http://qlikviewcookbook.com