Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

cancel
Showing results for 
Search instead for 
Did you mean: 
rtamagnini
Partner
Partner

DSC and QWS Disconnected - i can't see "System - Setup - Distribution Services"

I have one Windows server 2019 with QlikViewServer 64-bit Edition (x64) version 12.10.20800.0.
2 or 3 days ago the services DSC and QWS services go down.
On reboot it's ok for about +/-10 minutes and then it goes down again (DSC and QWS).
when I restart the services it doesn't solve.

in the log I have these errors :

"
...20211110T145000.218+0000 Error Failed to retrieve QDS info: System.ServiceModel.CommunicationException: QDS did not respond to request.
Last exception (for http://myserver:4720/QDS/Service😞 ANY did not respond to request.
Last exception (for http://myserver:4720/QDS/Service😞 The HTTP service located at http://myserver:4720/ANY/Service is unavailable. ...
Last exception (for http://myserver:4720/QDS/Service😞 The HTTP service located at http://myserver:4720/ANY/Service is unavailable. ...
20211110T145000.954+0000 Error System.ServiceModel.CommunicationException: QDS did not respond to request.
Last exception (for http://myserver:4720/QDS/Service😞 ANY did not respond to request.
Last exception (for http://myserver:4720/QDS/Service😞 The HTTP service located at http://myserver:4720/ANY/Service is unavailable. ...
Last exception (for http://myserver:4720/QDS/Service😞 The HTTP service located at http://myserver:4720/ANY/Service is unavailable. ...
..."


in the community I found this document which is exactly the same error I get :
https://community.qlik.com/t5/Knowledge/QlikView-Management-Server-thinks-new-QlikView-Server-is-als...

following step by step , I do not find the option described in point 7 . "In the QMC, navigate to System - Setup - Distribution Services"
i only have :
"Qlikview Servers"
"Directory Service Connectors"
"Qlikview Web Servers"
"Mail Server"

 

in the log I also find this line "DistributionGroupConfig: In the config file C:\ProgramData\QlikTech\ManagementService\DistributionGroups\DistributionGroupDefinition.xml. Clearing settings.". it's normal ?


can you help me ?

p.s.
(1) I'm thinking about upgrading the Qlikview version next month, but I would like to fix this problem first.
(2) I thought the problem was solved in the issue 1857227#M97039, but after all it didn't

8 Replies
rtamagnini
Partner
Partner
Author

attached the log from the start of the service until the error occurs

Maria_Halley
Support
Support

@rtamagnini

 

First, If you don't have a publisher license you will only get the below.

 

"Qlikview Servers"
"Directory Service Connectors"
"Qlikview Web Servers"
"Mail Server"

 

So if you don't have a publisher this is normal.

 

But that doesn't help with your issue of course

 

You say that the DSC and QWS goes down, but the logs attached complains about QDS.  

 

Does the services actually stop? Or do they stop responding?

 

I would check the windows event logs, the logs for the individual QlikView services and the recourses on the server, to start with

rtamagnini
Partner
Partner
Author

Hi Maria,

in the QMC I got an orange bar with : 3 services are down, at the same time I get the messages in the ManagementService log of "Error Failed to retrieve QDS info".

DSC and QVWS are Disconnect (at QMC).

Qlik services in windows service are running and never go down.

Curiously today after the services were down for 30 minutes they came up and in the log I got this message

"...
20211111T102908.270+0000 Error Failed to retrieve QDS info: System.ServiceModel.CommunicationException: QDS did not respond to request.
Last exception (for http://pqkvapp01:4720/QDS/Service😞 ANY did not respond to request.
Last exception (for http://pqkvapp01:4720/QDS/Service😞 The HTTP service located at http:/...
Last exception (for http://pqkvapp01:4720/QDS/Service😞 The HTTP service located at http://...
20211111T102928.586+0000 Information SendSaveConfiguration START"

But right now that I'm writing you this answer it's gone down again in the QMC (the DSC and QVWS services)

And more lines in the log with the error appear.

in the attachment I send you my application event.log and the log of managmentservices

 

Regards

Ricardo

 

 

 

Chip_Matejowsky
Support
Support

Hi @rtamagnini,

Suggest that you start by ensuring QMS logging is set to debug level and then check the QMS logs for errors or warnings. The default location for QMS logs is %ProgramData%\QlikTech\ManagementService\Log.  Also, note that support for version 12.10 ended in November, 2019.  So if you need to contact Qlik Support for assistance for this environment, you'll need to be running a supported version - 12.50 or 12.60.

 

Best Regards

Sr. Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
rtamagnini
Partner
Partner
Author

Hi Chip,

Debug logging already is and was already on.

so the log I sent you in the attachment should already have all the information

 

do you think i should upgrade even with these errors?

Chip_Matejowsky
Support
Support

@rtamagnini,

This is a single node installation, with all QV services running on one Windows server?  Seems that the QDS, QVWS and DSC services are losing communication with QMS periodically.  Do you have anti-virus (or any other scanning software that places locks on files) running?  Could be that there are locks being placed on the files QMS needs to communicate with and therefore cannot.

If you need to engage with Qlik Support, then you'll need to be running a supported version, so yes an upgrade of your environment would be required.

 

Best Regards

Sr. Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!
rtamagnini
Partner
Partner
Author

Hi Chip,

 

we had anti-virus, removed and rebooted the server.
when it started, the services were just below.
attached the management services log and the console prompt screen.

 

do you know ao long takes the upgrade process? 

 

Regards

Ricardo

rtamagnini
Partner
Partner
Author

and yes it's single node installation, with all QV services running on one Windows server.