Skip to main content
Announcements
Discover what’s possible with embedded analytics! March 6, 10 AM ET SIGN UP!
cancel
Showing results for 
Search instead for 
Did you mean: 
TanayModhe
Contributor
Contributor

QlikView access point "login failed" after upgrade.

Hi There,

We recently upgraded our QA And Test environments from 12.40.20300 to May 2022 SR1. After upgrade, when we go to access point it shows login failed, but as soon as we click on cancel we are able to login and view access point..

Any one facing same issue or have any resolution for this.

Labels (2)
3 Solutions

Accepted Solutions
Albert_Candelario

Hello all,

After investigation we have also found that adding the following setting in C:\Program Files\QlikView\Server\Web Server\QVWebServer.exe.config

<add key="StrictRedirection" value="false" />

In the <appsettings>….</appsettings>

Please make sure to take a backup of that file before and restart the QVWS service afterwards.

We are gathering the details in case IIS is used as webserver.

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer

View solution in original post

Albert_Candelario

Hello all,

For IIS please edit the seetings of the IIS manager->QvAjaxZFC ->Application Settings->Explore->Web.config

<add key="StrictRedirection" value="false" />

In the <appsettings>….</appsettings>

Thanks @Filippo_Nicolussi_P 

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer

View solution in original post

Vegar
MVP
MVP

I can confirm that the StrictRedirection=False did solve the issue in my case.

An alternative way for setting that parameter is to do it in the IIS manager.

 

Go to Default Website -> QvAjaxZfc -> Application Settings

Create (or adjust) the StrictRedirection parameter.

Name: " StrictRedirection"

Value: "false"

@TanayModhe : please mark this question as solved if you find one of the answers to help you solve your issue. This will be helpful information to future users running into a similar issue.

View solution in original post

7 Replies
Albert_Candelario

Hello @TanayModhe ,

Thanks for posting.

What kind of authentication are you using? Are you using ticketing? I have seen some challenges with it after upgrading.

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer
Vegar
MVP
MVP

I have a similar issue on a freshly installed May 2022 SR1 environment.

I also found two persons with similar issues in this case: https://community.qlik.com/t5/App-Development/Can-not-use-Webticket-to-login-Server-12-4-update-to-1...

TanayModhe
Contributor
Contributor
Author

Hi @Albert_Candelario ,

Yes we are using web ticket, Do you have some kind of workaround or resolution for the issue.

Thanks,

Tanay

Albert_Candelario

Hello @TanayModhe ,

I have seen a resolution has been provided on Solved: Can not use Webticket to login (Server 12.4 update... - Qlik Community - 1994377 by a community member.

Does this also work for you?

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer
Albert_Candelario

Hello all,

After investigation we have also found that adding the following setting in C:\Program Files\QlikView\Server\Web Server\QVWebServer.exe.config

<add key="StrictRedirection" value="false" />

In the <appsettings>….</appsettings>

Please make sure to take a backup of that file before and restart the QVWS service afterwards.

We are gathering the details in case IIS is used as webserver.

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer
Albert_Candelario

Hello all,

For IIS please edit the seetings of the IIS manager->QvAjaxZFC ->Application Settings->Explore->Web.config

<add key="StrictRedirection" value="false" />

In the <appsettings>….</appsettings>

Thanks @Filippo_Nicolussi_P 

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer
Vegar
MVP
MVP

I can confirm that the StrictRedirection=False did solve the issue in my case.

An alternative way for setting that parameter is to do it in the IIS manager.

 

Go to Default Website -> QvAjaxZfc -> Application Settings

Create (or adjust) the StrictRedirection parameter.

Name: " StrictRedirection"

Value: "false"

@TanayModhe : please mark this question as solved if you find one of the answers to help you solve your issue. This will be helpful information to future users running into a similar issue.