Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

SSL configuration

We are trying to convert from http to https for our Qlikview server.  Because of some sensitive data in some dashboards, our security and network group want https before going production. We have tried multiple times using various documentation sources but cannot get it configured right. Our latest attempt had us follow these initial steps:

  1. Open the QlikView Management Console (QMC)
  2. Navigate to System – Setup – QlikView Web Server(QVWS) – General Tab
  3. Under the Communication section, the Port needs to be changed to 443 and the check box for “Use” https needs to be checked.
  4. Click Apply
  5. Type https://localhost/qlikview in new browser window and you should receive 'There is a problem with this website's security certificate.' message.

Instead of the certificate problem message from #5, we simply get a 'website not found'.   We just didn't know what to do from that point, and we have our licenses purchased through a re-seller, and things have been a little slow getting technical assistance from them, so we thought we would try submitting a question, and seeing if anyone out here can help.

We have had Qlikview for over 15 months, and love the product.

Thanks.

David Zimmerman

1 Solution

Accepted Solutions
Giuseppe_Novello

David,

You need to use the whole fully qualify name instead of "localhost". This would be the server certificate, to verify this go to: Run.. > type MMC > File > add/remove Snap in> add Certificates> select computer account> next > Finish >hot ok> expend certificates > select "personal">certificate> here will show you the Fully Qualify Name for the issue certificate.

Best Regards,

Gio

Giuseppe Novello
Principal Technical Support Engineer @ Qlik

View solution in original post

19 Replies
Giuseppe_Novello

David,

You need to use the whole fully qualify name instead of "localhost". This would be the server certificate, to verify this go to: Run.. > type MMC > File > add/remove Snap in> add Certificates> select computer account> next > Finish >hot ok> expend certificates > select "personal">certificate> here will show you the Fully Qualify Name for the issue certificate.

Best Regards,

Gio

Giuseppe Novello
Principal Technical Support Engineer @ Qlik
Not applicable
Author

Gio,

Thanks for the reply. We got these instructions from our Qlikview reseller representative. The instructions actually said to test using locahost, and to expect a message like ‘There’s a problem with this web site’s certificate’. Since we didn’t get that message (we got ‘Web site not found’), we stopped the ssl config process. Our network guy didn’t want to go ahead with the certificate registration.

Hope this makes sense. We were just trying to follow the instructions document we received.

David

Giuseppe_Novello

David,

Can you please provide a copy of the documentation that was provided? Also, are you sure the Qlikview webserver service is running?

Giuseppe Novello
Principal Technical Support Engineer @ Qlik
Not applicable
Author

We started on page 24 with section 4.2 – configuring Qlikview web server to use SSL and we get stopped on 4.3 Testing SSL (port 443).

Not applicable
Author

Yes, the qlikview webserver service is running. Its status shows running on the QMC.

Giuseppe_Novello

just want to confirm, you trying localhost in the host server?

Giuseppe Novello
Principal Technical Support Engineer @ Qlik
Not applicable
Author

Correct. Our network guy was remoted into the Qlikview server, and was following instructions in sections 4.2 and 4.3 of the attached document. And the instructions say to use localhost, so the system should hopefully resolve the name correctly given that he’s logged into the server.

vincent_ardiet
Specialist
Specialist

Hi David,

I'm encountering the same kind of issues, I just find this thread http://community.qlik.com/message/222216 but I haven't already tested. In the attached Word document, at pages 15 and 16 (regarding your OS version) there is the "bind" part. Maybe it's the solution. I will personnaly try tomorrow.

Regards,

Vincent


Not applicable
Author

Vincent,

We think we figured out our issue. Since we were running Qlikview’s web server, portions of the SSL certificate setup instructions our network guy was bypassing, thinking it didn’t apply. A guy from our architecture group took a second look at the instructions, and convinced him to just try setting up the SSL certifate part under IIS. I tried it yesterday afternoon, and it worked.

I don’t know all the particulars they did, but I assume if they had just followed the SSL parts that applied in those earlier pages, we probably wouldn’t have had an issue.

So it just took a second pair of eyes, and someone willing to just try it.

Thanks for sharing.

David