Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
lgtsotrsdh
Creator
Creator

Alert E-mails When Reloading Using QVDistributionService.exe vs. QV.exe

Hi,

I have several applications configured with Post Reload alerts.  I've run into an interesting issue I'm hoping one of you has encounterd and can solve.

We reload our dashboards using a batch file calling either the QVDistributionService executable or the QV executable.  We prefer to use QVDistributionService since it runs totally in the background.  When I reload the dashboard using the QV.exe file, the Post Reload e-mails are delivered.  When I reload the dashboard using the QVDistributionServer executable, I get no e-mails.  However, if I followup that reload with a reload using the QV executable, I get two e-mails.

It seems that the e-mails generated during the QVDisributionService reload are stuck in a queue somewhere, and the reload using the QV.exe executable pushed this e-mail out along with the one it generates.

Has anyone ever encountered this issue?

Thanks,

Scott

4 Replies
biester
Specialist
Specialist

Hi Scott,

I wonder whether you had any news concerning this, as I'm experiencing the same issue right now (QV 11.20, SR 5). I made a very simple alert_test.qvw which should send mail on post reload (Interactive AND Batch), sending the system variable QVPath as mail body,  and tried:

1.) Reload via ManagementConsole (which actually is also QVDistributionService AFAIK): Alert worked, mails were sent.

2.) Reload via QVDistributionservice-executable (Batchmode) from the command line:

QVDistributionservice.exe -r=alert_test.qvw: Alert did NOT work, no mails were sent.

3.) Reload via qv.exe -r alert_test.qvw: Alert worked, TWO mails were sent; the first from Distributionservice and the second from Qv.exe (which I can tell from the QVPath).

4.) Reloading interactively with QVDesktop: Alert works (Alert-Popup comes up), but NO emails sent.

I really wonder what's going on here. It's all on the same machine (Server, Win 2008 64 bit, SP 2), under the same user ...... Reloading interactively with QVDesktop on other machines (where no QlikViewServer is installed)  works and SENDS mails .....

It's also a documentation problem, it should be made clear by QlikTech where alert emails should work and where they do not ..... So actually I'm stuck with the problem, not knowing whether it's a misconfiguration or a WAD (works as designed) ... It might be a hard and stony way to go through the issue with QlikView support I'm afraid ...

Rgds,

Joachim

german_avanzato
Creator
Creator

Do you solve the problem??

I am facing the same situation

biester
Specialist
Specialist

Yes and no: Reload via QVDistributionservice-executable (Batchmode) from the command line is still not working, but QlikTech support assured that this is no error but works as designed. Emails are only sent when reload is done from the QlikView ManagementConsole, NOT when using QVDistributionservice from command line.

Rgds,

Joachim

german_avanzato
Creator
Creator

Sorry for the delay in my response.

In my case, this works in the exact opposite way.

When I use the console or the QVDistributionservice-executable, no email is sent.

But, when I use the qv.exe or a user open-reload the document, the email is sent.

Its like the batchmode only work when the qv.exe is involved.

I finally "solved" this using .bat and powershell script.