Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
elie_issa
Creator II
Creator II

Allow Safe Macro

Dear All,

Can you please advise why i am getting the below popup message when trying to access some of my dashboards on the server ?

This problem is also affecting my nprinting reports when calling the dashboards.

allow safe macro.png

Note that i have checked "Allow macro execution on server " and "Allow unsafe macro execution on server" and still i have the same problem everyday.

macro server checked.png

ali_hijazihani.saghirmaleksafa

Thanks

1 Solution

Accepted Solutions
marcus_sommer
MVP & Luminary
MVP & Luminary

6 Replies
marcus_sommer
MVP & Luminary
MVP & Luminary

Your macro-window is independent from the qmc-settings because it's a end-user-setting if he/she want to allow the execution of macros or not - the logic is quite similar to the macro-handling by ms office.

Normally the user should have also have to enable the fourth option within this window "Always use this ..." which meant that the user-decision will be stored within the settings.ini in its user-profile and won't be asked again for it. Why it's greyed out I don't know.

- Marcus

pipuindia99
Creator III
Creator III

It should work as per your settings, but just try your server settings whether it stops your job. like security/privacy settings etc... sometimes it may stop your job if it is blocked.

elie_issa
Creator II
Creator II
Author

so what should i do to avoid this problem ? any steps to be done ?

marcus_sommer
MVP & Luminary
MVP & Luminary

pipuindia99
Creator III
Creator III

Before going to above said suggestion by Marcus, please do check from your side whether anyone of you have changed or modified the macros which was written earlier, if so save it and then open as it will always asks for allow macros whenever you modify something. this is just a check or thought from my side before going to settings.

elie_issa
Creator II
Creator II
Author

I change the "macrolaunchconfirmation" from 0 to 1 as suggested in the link above in the settings.ini

Hope it works.

Thanks