Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2023, a live, in-person thrill ride. April 17 - 20, 2023, in Las Vegas! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

AllowExecuteCommand setting violation detected

Hi Guys.

Error : AllowExecuteCommand setting violation detected

i'm getting this error while trying execute a batch files, it works fine when i'm using QV11, i just upgrade my qvs into QV12.

i've try this 2 solution :

1. i already try add this line : AllowExecuteCommand=1 in settings.ini (already restart all services but it doesn't work.)

2. already try to change user preference, tab security, check script (allow database write and execute statement)


i've seen this thread :

Allow EXECUTE statement in QlikView 12

https://community.qlik.com/thread/211162

Any Solution ?

Thanks.

21 Replies
yurituan
Contributor II
Contributor II

After searching across a community and finding no solution, decide to "tweak" the server.

I found a "Settings.ini" file in the path C:\Users\USER\AppData\Roaming\QlikTech\QlikViewBatch.

Yes, in the folder of the user running the service.

In my case solved the problem.

benjaminway
Contributor II
Contributor II

If you have a multi-node environment you only need to do this on the Publisher servers with QDS and only QDS needs to be restarted.  Verified on both 11.20 and 12.10.

umashankar_ts
Contributor III
Contributor III

This works for me as well. Updating the Settings.ini in the roaming profile works perfectly when added under windows path C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch

gballester
Creator
Creator

Excelent!!! Work for me!!!

warfollowmy_ver
Creator III
Creator III

At us this adjustment sometimes becomes = 0, it is necessary to put everything manually again.

Urgently! Again a terrible bug! EXECUTE Command Failed

dyhessyca
Contributor III
Contributor III

This works for me well. Tks so much!

warfollowmy_ver
Creator III
Creator III

Was there anyone other than me who met the situation when this setting itself becomes = 0 about once a month after the update to SR2-3?

lennyvz1
Partner - Contributor II
Partner - Contributor II

It looks like changing the settings.ini file is the proper solution to this issue, but I have a client experiencing the same issue as warfollowmy_verysoonwhere that setting reverts back to 0 at seemingly random times.

Has anyone seen an actual fix for the setting randomly resetting itself?

pgrenier
Partner - Creator III
Partner - Creator III

Thanks for this solution, it corrected the problem for us as well (QV 12.0.20400.0 SR5)

lennyvz1
Partner - Contributor II
Partner - Contributor II

It's a bug QV-12269

No real word on when the fix for it will be released.