Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
elaineng
Contributor
Contributor

Background color for column dimension in pivot table not different in client & access point

 

I've deployed a dashboard in with Qlikview client which contains a pivot table with column dimension (Type, Project) as per image below. The dimension background color is highlighted in light orange as per below.

Qlikview ClientQlikview Client

 

However, when I view the dashboard in access point. The column (Type & Project) has no color.Qlikview Access Point - WebQlikview Access Point - Web

 

Same issue when I export to excel from access point. Export from client has no issue.Qlikview export to excelQlikview export to excel

How can I resolve this issue?

5 Replies
New-Qlik
Creator II
Creator II

Hi,

How the color definition done in Pivot table ?

 

elaineng
Contributor
Contributor
Author

In the row dimension, I have any row called color code which determines the row color. The code as below:

=IF(ColorCode = 1, RGB (252, 228,214), IF(ColorCode = 2 , RGB (191,191,191)))

 

For the column dimension, it is determined by the type value. Which the formulas look like:

=IF(Type = 'AFTER MBW AWARD', RGB(153,255,204), if (Type = 'AFTER NSC AWARD', RGB(153,204,255), RGB(255,204,153)))

Brett_Bleess
Support (Former)
Support (Former)

Elaine, you did not mention which version you are running, that would be useful on this one, but one thing I can suggest just to get some further info would be to try the IE Plugin client from the AccessPoint, if you have the Desktop Client installed on your machine, you have the IE Plugin client, just use Internet Explorer as the web browser, and you should be able to then use the View Details link on the app thumbnail to choose the Plugin client instead of the Ajax client, I am curious if the Plugin works like the Desktop, as if it does, that would seem to indicate a potential defect in the server-side functionality for the Ajax client, and the best thing would be to open a support case, but depending upon the version you are running, there may be a newer SR you can try to see if things work there etc...  

The latest releases for the supported versions are:

11.20 SR19 11.20.13804 

12.10 SR11 12.10.20900

12.20 SR9 12.20.21000

12.30 SR3 12.30.20300

12.40 SR1 12.40.20100

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
elaineng
Contributor
Contributor
Author

Hi BrettBless, 

I am using 11.20 SR19 11.20.13804

I never use IE plugin as it leads to another problem. We used AD to login Qlikview access point,  when login password contains special character, it will never able to login from IE successfully. Other browser has not issue.

Brett_Bleess
Support (Former)
Support (Former)

Hey Elaine, I think I would go ahead and open a support case, we'll need a copy of the app when you do that, so we can test things for you to see if we can replicate etc., as if we can, we can definitely submit things to the engineers at that point.  Glad you are on the latest SR too, if there is a problem and the engineers are willing to do a fix, that is the release it would go to as a patch etc...  Sorry I do not have anything better for you, the only thing of which I can think is there may be something wrong in a JavaScript somewhere would be my best hunch as to root cause.  We can test in the latest 12.40 SR1 release to see if things behave the same way there etc., that should help narrow things down pretty quickly.  If you do create the support case, you can definitely add this Community post thread link to the case as well as further information for the techs to check out.  

The only other thing I could offer is if you want to send me the app or a FTP link or something, you could do that as a private message if you want, and I can test things for you on my side to see what I see, and I can post things back here as to results.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.