Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Button Actions do not function once published to AccessPoint

I have several buttons which set variable values when clicked (Right click-->Properties-->Actions-->External-->Set Variable-->'MPG'), and various charts with conditional Show options(Right click-->Properties-->Layout-->Show-->Conditional-->vShowChart='MPG'). If the button 'MPG' is selected, it sets vShowChart equal to 'MPG' and the MPG chart becomes visible and the rest are hidden. All that works fine.

I have a problem after publishing the document to our AccessPoint... The buttons no longer change the variable values making it impossible to change the chart displayed. I have edited a few module settings. Tools-->Edit Module-->Requested Module Security-->System Access, and Tools-->Edit Module-->Current Local Security-->Only Safe Mode.

Can anyone tell me what I am doing wrong?

Thank you,

Rob

And yes, I did post this twice, but got zero responses to the first one and I would really appreciate the help.

error loading image

1 Solution

Accepted Solutions
jsn
Employee
Employee

I'm fairly certain actions were introduced with version 9 so in that case they will not work with QVS 8.5. You need to upgrade in order to utilize them in the server. Good practice is to keep the entire QV environment on the same version to avoid situations like these where new features in developer don't work on the server.

View solution in original post

6 Replies
Not applicable
Author

I've used action buttons exactly like you have in several applications and had no problems with the published version working either in ajax or IEplugin.

As you are usuing the built in functions and not macros to change the variable then then module settings should have no effect however i would query what version of qlikview you are running on the server. I can vouch for 9SR4 giving the desired results.

in your load script i would also put a line like


set vShowChart=null();


to effectively "dim" the variable, not a must but good practice i think.

Not applicable
Author

AccessPoint 8.5, maybe SR5 but I am not exactly sure

Not applicable
Author

Sorry i'm not familair with 8.5 so i think it may be a bug with it.

If you can get the server upgraded to version 9 i think that would go a long way to fixing your issue (and many oterh issues you might not have cam across yet)

jsn
Employee
Employee

I'm fairly certain actions were introduced with version 9 so in that case they will not work with QVS 8.5. You need to upgrade in order to utilize them in the server. Good practice is to keep the entire QV environment on the same version to avoid situations like these where new features in developer don't work on the server.

Not applicable
Author

I'd say you guys are right... Instead of using the Set Variable button actions, I am going to use macros. I have no idea when we'll upgrade here... Thanks for the help!

Rob

Not applicable
Author

Hi

Does anybody know if I can use in QV 9 SR5 the actions of Qlikview instead the macros?, for example use Actions > Select in Field

Regards

Orlando