Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Action-Packed Learning Awaits! QlikWorld 2023. April 17 - 20 in Las Vegas: REGISTER NOW
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Cannot retrieve data from Access 2007 database

I'm able to connect to my MS Access database using both the ODBC (MS Access) and OLE DB ('Microsoft Office 12 Access Database)... methods.  In the wizard, I can see the list of tables within the database.  However, I cannot see any fields upon selecting a table and, subsequently cannot load any data.

Here is the message I receive for the ODBC version upon 'Reload':

SQL##f - SqlState: 42000, ErrorCode: 4294965389, ErrorMsg: [Microsoft][ODBC Microsoft Access Driver] Record(s) cannot be read; no read permission on 'tblAccount'.



FROM tblAccount

I checked the permissions on the Access database however there does not appear to be any restrictions.  Any thoughts?


3 Replies

if your system is of 64 bit use (select) force -32 bit  in script editor

Contributor II
Contributor II

Thanks for your reply.  I selected 32-bit but have the same result.

Not applicable

Did you solve this issue? I have a similar problem where I cannot connect to the Access DB at all. I get the same error code as you 4294965389, but with a different error message "You do not have the necessary permissions to use the '|' object. Have your system administrator or the person who created this object establish the appropriate permissions for you.

The database consist only of a linked SharePoint table/list.