Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
supriyabiware
Creator
Creator

Color Expression when expression is set analysis

Hello All,

My Chart expression is as below

=Count({1<YearMonth = {"$(=$(vPreviousYearMonth))"},
DEPARTMENT                          = $:: DEPARTMENT,
SUBDEPARTMENT                 = $::SUBDEPARTMENT,
ASSIGNMENT_GROUP         = $::ASSIGNMENT_GROUP,
PRODUCT_TEAM_SC            = $::PRODUCT_TEAM_SC,
AREA                                            = $::AREA>}distinct INCIDENT_ID)

And my color expression is 

=if(SERVICE='Advanced Support', $(ColorA1),if(SERVICE='Support',$(ColorA2),if(SERVICE='Others',$(ColorOthers))))

But still somehow when i drill down on chart it doesnt give proper colors at lower level .

 

Any help??

 

Regards,

Supriya.

7 Replies
agigliotti
Partner
Partner

what about your chart dimension?

supriyabiware
Creator
Creator
Author

Hi,

Dimension is cyclic dimension (Dept, sub Dept, Assigned Group)

 

agigliotti
Partner
Partner

could you post the qvw to look in ? otherwise I can't help you find out why.

supriyabiware
Creator
Creator
Author

here goes. i need consistent colors even after selecting any dimensions or filters

supriyabiware
Creator
Creator
Author

if i remove 'One color gradient' option from each color. seems to be working ok.

 

not sure why the formula mixes all the colors when 'one color gradient' is on.

jochem_zw
Partner
Partner

You Have to add your set analysis from the expression to the background color expression. The current active VW_Service is based on your selection for year etc. 

Brett_Bleess
Support (Former)
Support (Former)

Did the last post get you what you needed?  If so, do not forget to return to the thread and use the Accept as Solution button on his post to give him credit for the assistance and let other Members know that worked.  If you did something different, please consider posting that and then mark it as the solution, and if you still need further help, leave an update for us.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.