Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
gshockxcc
Creator
Creator

Commenting with Dynamic Update

Hi all,

     I am very new to Qlikview, but I have had a LOT of help to run before I know how to walk, so to speak.  I recently found this post which is exactly what I want to be able to add comments to a Qlikview app.

QlikView Commenting with Dynamic Update (no extension needed)

I am trying to implement this in my document.  When I add a comment and click OK, the Edit Module window pops up, and I don't know why.  I don't have any error messages that give me an indication of what's wrong.

Update: After commenting out pieces of the module, it appears that this is failing on in the "CreateComment" module.

    SET Result = ActiveDocument.DynamicUpdateCommand ( SQL_String )

Thanks in advance.

1 Solution

Accepted Solutions
gshockxcc
Creator
Creator
Author

After some follow up, my issue was resolved by setting the document properties --> Server --> Dynamic Update (checkbox).

Once I changed this, things started working, and I was able to debug the comment box objects.  I still have an issue with the tags, but I think that's my mistake, and not related to the macro.

ThanksDynUpdate.png

View solution in original post

6 Replies
Anonymous
Not applicable

Interesting thing...

I assume you didn't allow system access in the macro module.

ToniKautto
Employee
Employee

Do you have Dynamic Update enabled in your server license?

Check the LEF details in your QlikView Management Console.

2015-06-04 09_23_19-QlikView Management Console.png

gshockxcc
Creator
Creator
Author

No, we don't.  It appears that this would seem to be the cause of the problem!

I am following up with our Qlik representative.  Thanks for saving me a lot of time debugging this.

gshockxcc
Creator
Creator
Author

Yes, I checked to make sure that I did allow system access.

dgreenberg
Luminary Alumni
Luminary Alumni

Toni - could this Dynamic_Update;Yes be the key to my problem running dynamic update on the server?

I can only test in dev and this is what the license says:

Commenting with Dynamic Update

PRODUCTLEVEL;10;;2015-07-30

TIMELIMIT;VALUE;;2015-06-26

SPECIAL_EDITION;EVALUATION;;

SPECIAL_EDITION;TEST;;

NAMED_CAL_BY_MACHINE_ID;NO;;

TEST_EDITION;YES;;

NUMBER_OF_USERCALS;111;;

----

Would this prevent Dynamic Update from working on our Dev Server?

Thanks

Dan

gshockxcc
Creator
Creator
Author

After some follow up, my issue was resolved by setting the document properties --> Server --> Dynamic Update (checkbox).

Once I changed this, things started working, and I was able to debug the comment box objects.  I still have an issue with the tags, but I think that's my mistake, and not related to the macro.

ThanksDynUpdate.png