Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
suryakant241187
Partner
Partner

Error in ODBC Connection

Hi All,

I am getting below error while i am loading the data in qlikview.

SQL##f - SqlState: IM014, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application

ODBC CONNECT64 TO [Excel Files;DBQ=X:\ data\Employee data_31st_Dec_2017.xlsx]

Operating system is 32 bit.

Please help to solve the issue.

Regards,

Suryakant

1 Solution

Accepted Solutions
Chanty4u
Champion III
Champion III

Hi

Try selecting Force 32 Bit option in Expression Editor below the ODBC list box.

The Great ODBC Confusion

View solution in original post

10 Replies
Chanty4u
Champion III
Champion III

Hi

Try selecting Force 32 Bit option in Expression Editor below the ODBC list box.

The Great ODBC Confusion

View solution in original post

suryakant241187
Partner
Partner
Author

Hi,

I have already tried Check, Uncheck of 32 Bit option but its not working

Regards,

Suryakant

Chanty4u
Champion III
Champion III

same error: Resolved below did you check this?

Setup 32 bit ODBC by executing c:\windows\sysWOW64\odbcad32.exe.

In QV ODBC script statement click on "Force 32 bit" and redo the ODBC statement.  Click "Connect" button and select the ODBC source. Should be "ODBC CONNECT32 TO" as oposed to "ODBC CONNECT TO".

sharuta
Contributor II
Contributor II

You Need to use 32 bit connector:

ODBC CONNECT TO [Excel .....

Another method:

Directory;

LOAD [Field1],

     [Field2],

     [Field3]

FROM

X:\ data\MyFile.xlsx

(ooxml, embedded labels, table is Sheet1) ;

suryakant241187
Partner
Partner
Author

Hi,

Getiing Error:

ODBC read Failed.

Chanty4u
Champion III
Champion III

is this reason?

You need to check the bitness of the actual SQL ODBC Driver on the Server, not the bitness of the computers.  I am not sure if you are using and USER or SYSTEM DSN but you could check also to see if that DSN name is showing up on the 64 bit ODBC DataSource Administrator or your 32 bit one.  To check the 32 bit one, make sure you don't already have the ODBC Data Source Administrator running in 64 bit, your default, because it will still be showing the 64 bit DSNs.

sharuta
Contributor II
Contributor II

Try to create USER DSN in your OS to your File without QlikView. Perhaps problem in OS?

Try duplicate this operation on another Computer.

sharuta
Contributor II
Contributor II

I don't use USER or System DSN.

Example (OS maybe 32 or 64 QV file was migrate):

IF FileSize('..\EXCELReports\MyFile.xlsx') > 0 Then

Directory;

[xMyFile]:

LOAD

    A AS Field1,

     B AS Field2,

    'EUR' AS FLCurrency,

     Day(H) AS day_qv_sum,

    Month(H) AS month_qv_sum,

    Year(H) AS year_qv_sum,

    SUM(M) AS sum_FL_Sum

FROM

[..\EXCELReports\MyFile.xlsx]

(ooxml, explicit labels, header is 3 lines, table is Sheet1)

WHERE(IsNum(M))

Group by H,'EUR';

ENDIF

suryakant241187
Partner
Partner
Author

First i have done:

  • The 64-bit drivers are configured using C:\Windows\System32\odbcad32.exe
    (Can be started from the ControlPanel ˃ Adminstrative Tools > Data Sources (ODBC).)
  • and then Tried selecting Force 32 Bit option its worked for me.

Thanks