Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
rittermd
Master
Master

I need to not display some dimensions in stacked bar chart

I have a chart and a stacked bar chart in a container.  The regular chart does exactly what I want.  Out of say 15 Dimension values if only 3 have data then the chart/table only displays the 3 rows.  However, the bar chart is showing the bars in the 3 rows that have data but still shows all of the other Dimension Values that have no data.  I need to see if I can get rid of those.

Both are based on the same data.  However, the table just shows the Dimension with some aggregates.  The bar chart is stacked with 4 expressions and show results in percentages.

I realize that this might be hard to answer without seeing the application.  But I was hoping that there was an easy answer.

I do have the box checked in the bar chart to not display if zero.  That doesn't seem to do anything.

1 Solution

Accepted Solutions
Gysbert_Wassenaar

Then make sure none of the expressions is overriding the selection of your dimension using set analysis. And that the Suppress Zero-values and Suppress Missing options are enabled. And that the Show All Values option of the dimension is disabled.


talk is cheap, supply exceeds demand

View solution in original post

5 Replies
maxim_senin
Partner
Partner

Hi Mark,

Are you going to provide a sample qwv?

Best regards,

Maxim

Gysbert_Wassenaar

I'm guessing you are using two dimensions in your bar chart. In that case for a value of the first dimension there will be space reserved for a bar for each value of the second dimension if any expression returns a value for any combination of first and second dimension.


talk is cheap, supply exceeds demand
rittermd
Master
Master

I only have 1 dimension and 4 expressions that are stacked.

What I want is when a dimension value has no data to have the legend value for that dimension to not appear.

For example:

Let's say that there are 15 possible values for the Dimension.  Based on selections only 3 of the 15 have data.  So I want to see the 3 bars and the values on the Legend for them.  I want the rest of the bar chart to be empty.

Gysbert_Wassenaar

Then make sure none of the expressions is overriding the selection of your dimension using set analysis. And that the Suppress Zero-values and Suppress Missing options are enabled. And that the Show All Values option of the dimension is disabled.


talk is cheap, supply exceeds demand

View solution in original post

rittermd
Master
Master

Thank you.  You pointed me in the right direction.  I still have not fixed the issue yet. 

I have counts that I display in the pop-ups of the bar chart.  Based on what you said I disabled them and the chart behaved as I want it to. 

So there is something in the counts expression that is overriding my selections and causing all of the bars to display.