Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Image URL to Image

Hello all,

I am having a really issue here

In my sql database i have Product and Product Image columns

I want to Load the product code with the images in Qlikview, I have tried Bundle Info Load but it didn't work.

I created a table with the Product codes and the product images as expression with selecting Image in the representation drop down list but with no success as well

The Product code and last part of the image link are similar such as;

Product Code      Product Image

12345                    www.products.com/12345.jpg

I have tested on this image https://www.analyticsvidhya.com/blog/wp-content/uploads/2015/01/Qlikview.jpg still didn't work.

I am trying to avoid using Inline (if I have to list all the product codes and product images) as I have a very big list 5000+ products/images

Would you please be able to help?

Many thanks,

Amir

4 Replies
Anil_Babu_Samineni

How you create the Bundle Load in script from Qlikview. Can you show the script and that please show the image of object which you used

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
bujnakbranislav
Partner
Partner

Amir - take a look at my solution. My issue was that Images were stored in the local dir and I had to create URL link to map to those images. Database only included path to those images

Convert File Path into URL Link

also, had to add script to the load editor to create

Images:

NoConcatenate

LOAD


      "Image_Dir",         // Image Path

     "Images";             // Image Name

   

SQL SELECT


    dbo."Image_Dir",

    dbo."Images"


   

FROM dbo;


// Break Images field into multiple fields -------- all my images were stored under the same value for each product (e.g, "Image1.jpg; Image2.jpg; Image3.jpg; ...."


for y=1 to 100


ImagesTemp:

CROSSTABLE(ImageId, ImageName, 1)

LOAD


     Image_Dir,

    subfield(Images,';',$(y)) as Image$(y)

   

RESIDENT Images;


NEXT y;



DROP TABLE Images;


/*----------------------------------------------------*/

ImagesTemp2:

noconcatenate

LOAD *


RESIDENT ImagesTemp


where ImageName like upper('*.JPG*');


DROP TABLE ImagesTemp;

Frank_Hartmann
Master II
Master II

see attached qvw

Unbenannt.png

hope this helps

Irishtone
Contributor II
Contributor II

Hi All,

 

Even Frank's linked qvw is displaying as a link for me.

Does anyone have any clue what's going wrong for me ?

(I have checked the .ini file in my settings and tried options 1 & 2 for the "AllowGeneralAccessToImagesThroughURL=" setting.

Capture102119.JPG