Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Action-Packed Learning Awaits! QlikWorld 2023. April 17 - 20 in Las Vegas: REGISTER NOW
Showing results for 
Search instead for 
Did you mean: 
Partner - Creator III
Partner - Creator III

Instability reloading documents


I would like to raise the following issue.

We are using batch file wich is executed by windows scheduller to reload QV documents. This is done now via QV Jobs, because we need to reload several documents in a sequence. In a batch file we tried to use both QV.EXE and QVDistributionService.EXE to reload documents. We tried this on QV9 and QV10. Documents are 1..5 GB of size.

The problem is, that ocasionally QV freezes, I can see QV.EXE in memory, but nothing happens, Task manager does not show activity, documents are not loaded or not saved. Document logs do not show any errors, sometimes windows explorer shose size 0, but if I open the log with notepad it shows some information, but the log file isn't complete.

If I run the batch manually it allways runs successfully.

Does anyone face similar problems? Could someone suggest any solution to solve the instabillity problems? Thank you very much.


7 Replies
Not applicable

Hello Pranskus,

                          I hope the QV instances are not killed in process in Task Manager ,

try to kill manually first and check if it works fine.

Partner - Creator III
Partner - Creator III

Hi Pranskus, yes i have had a very similar issue but using xp_cmdshell in SQL Server to run the qv.exe unfortunately never managed to find out why!

Not applicable

Hi sbaldwin,

                     1. Might be CPU process allocation.

                     2. Shared server with Multi task system.

                     3. Need to ensure once you open Qlikview application over web, if you terminate the application also

                         it will not release the memory.



Not applicable

I am having the almost exact same issue, but it appears to only have recently started occurring...

"C:\Program Files\QlikView\Qv.exe" /vvPrintReports=1 /vvMailReports=0 /NoSecurity "E:\QlikView\Access Point\File-Test.qvw"

So this .BAT has a Macro, that when executed was designed to print a PDF using the QlikViewPDF (old version).

Just recently, we've noticed that this fails in Task Scheduler in the similar behavior as described by OP:

... qv.exe appears to 'hang' at the point that it would print the document

... the step directly before the PDF would be generated is confirmed to be working properly (we setup a single line to simply delete a specific file, and it behaved appropriately)

... the document intended to print never appears

... so it also never reaches the end of the Macro that is intended to kickoff when vPrintReports is passed over (the end of the macro quits the active document automatically)

Again: all of this works when running the .BAT manually, or if we set Task Scheduler to run "Only when user is logged on," but if we set it to run "Whether the user is logged on or not," it fails every time.

This only started happening earlier this week, after months of proper behavior.

Searching around the forums, I've seen a few others recently report this, and if I can collect a few other posts, I'll tag them here also.

Not applicable

Not applicable

After trying a bunch of different things over a couple of weeks I tried a couple of things:

Running the command with, and without the /NoSecurity flag

(in your situation):

"C:\Program Files\QlikView\qv.exe" /NoSecurity "C:\QlikView\Data\App.qvw"

.. and also, I tried kicking the job off (while configured to run as '... whether logged in or not') as another user who is setup as an admin on that same system.

After doing this, for some bizarre reason, the job runs fine again as the intended user, and whether they are logged in or not.

No idea why or how, but this resolved my issue.

Not applicable

Hi, I have exactly the same issue. I reload documents with file batch scheduled. During the last days the problem is increased, now it happens very often and also on many documents that doesn't launch any macro.

QV.EXE just freeze before starting. I've noticed that sometimes QV.EXE freeze also when I launch it alone from my desktop icon... so it shouldn't be something related to documents but something about QV.EXE itself or something at operating system level

Another reason I suppose the problem it's not related to documents, it's that every document freeze completely random