Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld online is next week! REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
melwilson
Contributor II
Contributor II

Launching an Excel File from a button not working in Accesspoint

Hi,

I am trying to launch an excel spreadsheet from a button in QlikView 11.2. When I try it during development it works. When I try it in Webview or Accesspoint it doesn't.

Am I doing this incorrectly:

I go into the button and create an Action - Launch

Then put in the application S:\Excel Spreadsheets\P&L Report.xlsx (which it says 'the system can't find the drive specified')

I have also tried using the full server name instead of the S drive.   \\QlikServ\Excel Spreadsheets\P&L Report.xlsx ( which comes back with a grey box saying it's trying to open a window in Chrome or HTTP 404 in IE)

 

Can anyone point me in the right direction ?

Thanks,

Mel.

1 Solution

Accepted Solutions
jonathandienst
Partner
Partner

When launching an application from access point, the action will run on the server. Is Excel installed on the server? Your action path might also need the complete command line to Excel (on the server).

You can't use mapped paths (like S:....) as these mappings exist  in your user context only and usually service accounts will not recognize it.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein

View solution in original post

5 Replies
jonathandienst
Partner
Partner

When launching an application from access point, the action will run on the server. Is Excel installed on the server? Your action path might also need the complete command line to Excel (on the server).

You can't use mapped paths (like S:....) as these mappings exist  in your user context only and usually service accounts will not recognize it.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
melwilson
Contributor II
Contributor II
Author

Hi, Jonty.

Thankyou for the reply. I have used the complete path and have avoided using mapped drives. I have also checked that that the server has Excel on it.

I'm getting an HTTP 404 message in IE which I'm assuming is a security issue. Just to confirm with you, when opening an excel spreadsheet from within my dashboard in accesspoint , would I be using my security profile on folder security or the Qlik service profile ? My technical understanding of accesspoint is a bit limited, I'm afraid.

Thanks,

Mel 

jonathandienst
Partner
Partner

The Qlikview service account profile.

404 is a file not found error. Are you sure the path is correct?

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
melwilson
Contributor II
Contributor II
Author

Hi, Jonty.

Thanks very much for your reply, Jonty. It is greatly appreciated.

Yes, I think everything is correct. The address \\QlikServ\Excel Spreadsheets\P&L Report.xlsx  is working correctly when I launch it within the dashboard but if I go to WebView or Accesspoint it doesn't work - it tells me it cannot find it, and to make sure my path is correct.

What I did notice is that when I launch it within the dashboard I do get a message saying 'Approve Application for Launch ?' which I click 'Ok' on.

Would this be stopping it from working in WebView as it doesn't go through that process ?

 

Mel

melwilson
Contributor II
Contributor II
Author

Right. I think I have it working (partially).

I'm using a URL to  open thew folder using the following details:

file:\\QlikServ\Excel Spreadsheets\

The user can then select the spreadsheet themselves from within the folder.

The only issue is that this works in IE but doesn't in Google Chrome. I assume this must be a Chrome setting that needs to change.

Mel