Skip to main content
Announcements
See why Qlik is a Leader in the 2024 Gartner® Magic Quadrant™ for Analytics & BI Platforms. Download Now
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Loading data in script editor issue.

HI,

I am loading data from Script Editor Like below.

AB1:

Load

a,

b,

c

from (Source);

The issue is ,my datamodel looks something like below:

AB1:

AB1.a

AB1.b

AB1.c

Where as I only want my table to have only column names instead of table name.column name.

Thank you for the help.

Thanks,

Alva.

11 Replies
sunny_talwar

You might have a qualify statement before you load the table

QUALIFY *;

You need to comment it out and it should fix the issue for you.

Not applicable
Author

No,I dont have any qualify statement...is there any setting in the document that I have to change ?

sunny_talwar

Can you share the complete script? Make sure that there is not hidden script?

maxgro
MVP
MVP

does your data come from a .qvd file?

you can rename the fields

AB1:

load

     AB1.a as a,

     AB1.b as b,

     AB1.c as c

from

     ....

Not applicable
Author

No..it is coming from the .csv file directly.

jonathandienst
Partner - Champion III
Partner - Champion III

Well you can still rename the fields as maxgro suggested.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
t_chetirbok
Creator III
Creator III

So, if you are sure that there is not QUALIFY, you can write UNQUALIFY *; before load. Maybe it'll help.

jonathandienst
Partner - Champion III
Partner - Champion III

UNQUALIFY will reverse a QUALIFy statement. It will not remove the table prefix if  it is coming like that from the csv source file.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
t_chetirbok
Creator III
Creator III

I think fileds in csv name like a,b,c and after load fields start name with prefix AB1.

Pavana.alvashetty‌, is'nt it?