Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
erric3210
Contributor III
Contributor III

Strange Issue or Bug in Qlikview (Select from Table)

Hi All,

I recently had a  new issue in Qlikview which I've never seen before. First, I was thinking to escalate this issue by registering a case with QlikTech. But I thought this might me a known issue for some users.

I was just pulling 4 fields from SQL and my query in Qlikview is:

Table_1:

Select ID, Code,  Area, Date FROM ABC;

After Reload, what it is doing for some ID's, it is clubbing them into one against one code but in source data they are not related to each other.

But when during load time when I use Where condition for one particular ID then data is coming different which is right and when I'm not using any Where condition that it is clubbing 2 names against 1 ID.

Let me explain with an example.

Issue_Repoprted1.png

 

When using both ID's in where condition then also it is giving wrong result and it is clubbing them against one code.

Does anyone has ever faced such strange issue or do I need to register a Case with QlikTech.

 

Regards,

Eric

Labels (2)
5 Replies
rwunderlich

Can you show a screenshot of your data model?

erric3210
Contributor III
Contributor III
Author

Hi Rob,

Thanks for replying. Actually, I'm just working with a single table and this is giving me the wrong result.

Honestly speaking, I'm not able to justify this behavior to the Business Users.

Qlikview is displaying result which is not in the source table.

Regards,

Eric

erric3210
Contributor III
Contributor III
Author

Hi,

Should I register a case with QlikTech for this Bug.

Regards,

Eric

rwunderlich

Hard to say without seeing what you are doing/seeing in Qlik. What you posted looks like something from excel. Sure, go ahead and contact Qlik support. They can help you sort this. let us know what you find out.

-Rob

erric3210
Contributor III
Contributor III
Author

Hi Rob,

This is a Output from SQL which I'm using in Qlikview.

Regards,

Eric