Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Web Server Service is not running

Hi ,

QV Web server service is showing as disconnected in the Qlikview Management Console.But in the Services.msc all the services are running fine. I am not able to find the reason for the issue. It is contradictory Since it is showing as disconnected in management console and it is working in Services.msc. Please suggest

13 Replies
Not applicable
Author

Reinstall the Qvs again .. and then see the sevices

Not applicable
Author

Thanks for you suggestion. But ideally since i tried to change the Accesspoint to IIS Server i am facing this issue. I dont think we need reinstall to fix the issue. i tried the log files it is showing as warning Aborted.

Any idea please suggest

Not applicable
Author

change the port of the Config.xml to 8080 from 80

you will find this file on c:/documents / alluser/application data/qlik view / qvserver / config.xml

Not applicable
Author

Hi,

If i am changing the Accesspoint to the default accesspoint the service is running fine.It is not running in the management console only if it is mapped to IIS server.

Not applicable
Author

Did you try to restart the Qlikview Web Server service. This fulfills the old AccessPoint functions.

Not applicable
Author

I tried all the options. IIS server is also working fine. In services.msc also all the services are running fine.But only in the QMC the QVWS service is showing as disconnected.

Bjorn_Wedbratt
Support
Support

If you're going to use IIS instead of QVWS do the following:

- Make sure you followed the instructions in ref. manual and created a new application pool in IIS to host the virtual folder /QvAjaxZfc. The identity of the pool must be a member of QlikView Administrators group

- In IIS management make sure Integrated Windows Authentication is turned on and Anonymous access is turned off on the file /QvajaxZfc/AccesspointSettings.aspx (I prefer to set the whole web site to IWA only, but this file must have IWA even if you plan to have anonymous access to Accesspoint etc)

- Check that you can browse to http://localhost/qvajaxzfc/accesspointsettings.aspx in IE. Pay attention to the zone in IE, it must be Local Intranet (should be default for localhost)

- Go to the tab Systems in QEMC and click on the folder Web Servers.

- Change the URL for QVWS from http://localhost:4750/qvws.asmx to http://localhost/QvAjaxZfc/Accesspointsettings.aspx

- Restart IIS and QVS

That should solve your issue with the web server not connecting to QEMC.

PS. If you don't plan to run QVWS at all there's no reason to have it running, not even installed. On the contrary it will only confuse you in the long run, because if the QVWS is started (for example if set to automatic and you reboot) it will take ownership of the URL:s used by QlikView and those URL will no longer be managed by IIS (so if you change settings etc in IIS the settings will no apply to the URL:s)

Not applicable
Author

Thanks Bjorn Wedbratt .

I have few Queries based on your reply.

Is it mandatory that Qlikview has to run seperate Application pool? Since i have not created the seperate Application pool.But still it is working fine.

Bjorn_Wedbratt
Support
Support

No, you don't need to create a separate Application Pool. You could simply change the identity of Default App Pool to use the account running QVS (or have a dedicated app pool account and add it to QlikView Administrators). But this shouldn't be done if hosting other applications on the same IIS as it might break other web apps.

The reason why you need to have at least /QvAjaxZfc hosted in an application pool running in the context of a domain account (or local account) is to be able to connect the "web server" into QEMC. In this case the identity of the app pool must be a member of QlikView Admin group.