Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
cparussell
Contributor III
Contributor III

Why are my axis labels not centering on the bar clusters once the app is displayed on the web?

I've come to expect there will be subtle display differences once my QlikView file leaves development and goes onto the web, and I've learned to compensate somewhat for those differences. But this one I can't find a remedy for. The Axis dimension labels shift from being centered on the bars to being more top-aligned (see attached png). Client is complaining. Anything I can do?

 
 
Labels (3)
3 Replies
Brett_Bleess
Support (Former)
Support (Former)

Do me a favor, in the desktop client, enable the WebView mode to see if things are the same that way...

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/Client/Content/QV_QlikView/Ajax/WebView_In...

That should hopefully allow you to see things the same way etc. such that you can get it setup as you want in WebView, which will then xfer perfectly over to the Ajax client on the server.  Be sure also that your desktop client is running the same version as the QVServer too, that should ensure everything comes out correctly.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
cparussell
Contributor III
Contributor III
Author

Everything looks perfect in WebView.  Things change when we push the tool to our production server. I verified that the servers is running an older version of the app than our desktop client.

We are planning an upgrade, so will see if upgrading the app on the server addresses the issue of the labels not centering and some other things, like imported graphics not scaling properly and shifts in alignment of sheet objects.

Thanks for your reply, and I'll post an update once we upgrade the servers. 

Regards,

Russell

Brett_Bleess
Support (Former)
Support (Former)

The only other thing would be to ensure the fonts you are using in your Desktop Client exist on the QVServer, if not, we use a substitute font, and that might throw the alignment off too, sorry I forgot about that on the first reply...

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.