Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

problem load with spaces

During Load I need to work with leading spaces.

TEST:

Load

' no class' as ABC,

*

resident xyz;

In this case I see the correct value with a leading space " no class"

When I need a pre.load, the leading spaces are dropped

TEST:

Load *,

Field1;

Load

' no class' as ABC

Field2

Resident xyz,

The same happens with Inline Tables.

TEST:

Load * inline [

A

' no class'

' test'

'another test'

2

];

The field A shows all text without leading space!

Why  Qlikview removes leading spaces during a pre-load or in an Inline table.

Can it be avoided? I need leading spaces!!

Qlikview 11 SR 5

Thanks for your help

1 Solution

Accepted Solutions
Not applicable
Author

Try putting

Set Verbatim = 1;

at the start of your load script

View solution in original post

8 Replies
tresesco
MVP
MVP

Try using text(), like:

Load

          Text(A) as A ;

Load * inline [

A

' no class'

' test'

'another test'

2

];

Anonymous
Not applicable
Author

no change, the same behaviour

Not applicable
Author

Try putting

Set Verbatim = 1;

at the start of your load script

View solution in original post

its_anandrjs

Update new check now

Write like below script

TEST:

LOAD *,Text(A) as TextA;

Load * inline [

A

' no class'

' test'

'another test'

2

];

And plot field TextA

tresesco
MVP
MVP

set Verbatim = 1;      in the script

its_anandrjs

Did you try Text(FieldName) it works for me


TEST:

LOAD *,Text(A) as TextA;

Load * inline [

A

' no class'

' test'

'another test'

2

];

See the output

Textop.png

Anonymous
Not applicable
Author

it only works with "set Verbatim=1"

without that, the preleading spaces are removed

Not applicable
Author

Another way, instead Set Verbatim, is to use Hard Space Char(160). So, it should be like:

let vHardSpace = Chr(160)

;

Load * inline [

F1

$(vHardSpace)My text

]

;