Skip to main content
Announcements
Product Release Webinar: Qlik Insider airing December 6! REGISTER TODAY!
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

qvb set CPU priority

Hi Experts,

I have a distributed setup installed for my company. Server 1 has QVS & QWS. Server 2 has QDS, DSC & QMC. Everything is set up successfully.

On server 2 when the loads are running through the qvb (reload engine) they are much slower than earlier (previously everything was on one server). We noted that CPU priority for qvb is set to 'Below Normal' in the task manager (windows server 2012).

How can we set this priority to be High/Normal permanently?

Help much appreciated.

Thank you.

Regards,

Pramod K

5 Replies
maksim_senin
Partner - Creator III
Partner - Creator III

Hi Pramod,

As an option - start the service manually, please follow the START command help:

START ["title"] [/Dpath] [/MIN] [/MAX] [/SEPARATE | /SHARED]
  [/LOW | /NORMAL | /HIGH | /REALTIME | /ABOVENORMAL | /BELOWNORMAL]
  [/WAIT] [command/program]
  [parameters]

Don't know whether it's possible to tune it via UI, maybe it's stored in registry.

Best regards,

Maxim

rohit214
Creator III
Creator III

HI Promod,

What are the RAM size for server1 and server2?

If server 1 has more memory to as compared server2 then install QDS in server2 and rest of services in server 1. and then check. Because i faced the same senario.

Thanks

Rohit

Not applicable
Author

Hi Rohit

Server 1 has 128 GB RAM and Server 2 has 64 GB RAM.

So do we have a document note somewhere regarding this?

rohit214
Creator III
Creator III

HI,

No because when the users are accessiing the documents so in most of senario the RAm and CPU utilization is more for that server where QVS QWS services are installed and keep only QDS service in server2 rest of all in server 1 and check also workset Min and Max  CPU %.

And i don't think CPU priority for qvb does make any effect on performace, It might be your  task priority.

Thanks

Rohit

Not applicable
Author

How do I set my task priority?

I have set the Workset as 70 and 90 %