Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
thomaswrieck
Partner
Partner

script execute flag

Hi,

in one of a qv application I have an execute command in the script.

The code is this :

LET vFTPScript='"D:\QlikView Storage\UAT\InternalReports\06-FR\xxxx\xxxxxxFTP.bat" "$(vRepExpLoc)"';

That defines the batch to be executed and its parameter (the file to be uploaded).

The batch will be kicked off later in the script by : execute $(vFTPScript); /*Upload Report to FTP Location */

Now, I get a message box "Security Alert - Unauthorized Statement", a lot of bla bla regarding execute flag etc. To fix this permanently I should check the execute flag for the script. When I click on "Override Security, Execute this Statement" the command works as expected.

What does that mean .... how to I check the execute option for the script ?

Thanks a lot ...

Thomas

6 Replies
Not applicable

Hi Thomas, Did you got this error fixed. I am facing the same issue. Please let me know the solution. Thanks.

thomaswrieck
Partner
Partner
Author

Hi,

yes ... you need to set the user security like this ...

Not applicable

I am using the following solution:

1. In the window with the load script, under tab "Settings" check the "Can Execute External Programs":

2. Then when you will run the load script first time, the following window will appear:

Just take the "Give System Access"; and the when you run load script next time, no alerts will appear.

Not applicable

How do I set the execute flag? I can't see the screenshots in the answers above.

Not applicable

Found it!

It's in the script itself. There's a tab Settings at the bottom.

Not applicable

Do this:

In the qvw document:

User preferences --> Security --> Script (check)

No window will appear after doing that!