Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Judicael
Partner - Contributor III
Partner - Contributor III

section access profiles user admin

 

Hello,

I create a session access fir reduction. Works Well but I want also get the profiles user

How can I do that, please ?

 

 

SECTION ACCESS;


SECTION_ACCESS_USERS:
LOAD
ACCESS,
UPPER(NTNAME) AS NTNAME,
PROCESS_REDUCTION,
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

SECTION APPLICATION;

 

LINK_PROFILE_USERS:
LOAD
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES,
PROFILES_USERS_QUALIFICATION
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

 

LOAD
PROFILES_USERS_QUALIFICATION,
PROFILES_USERS,
USERNAME,
VALIDATEUR,
VALIDATEUR_RESTREINT,
QUALIFICATEUR,
GESTIONNAIRE
FROM $(vFolderQvd)PROFILES_USERS_FINALE.qvd(qvd);

 

Thanks for your help.

 

Labels (1)
1 Solution

Accepted Solutions
Vegar
MVP
MVP

Try to run the script below in a separate application. It's your original script without the section access activated. Add a couple of list boxes, one per table. Click on the different NTNAMES fields to figure out what's happening.

//SECTION ACCESS;

SECTION_ACCESS_USERS:
LOAD
ACCESS,
UPPER(NTNAME) AS NTNAME,
PROCESS_REDUCTION,
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

//SECTION APPLICATION;

LINK_PROFILE_USERS:
LOAD
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES,
PROFILES_USERS_QUALIFICATION
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

 

LOAD
PROFILES_USERS_QUALIFICATION,
PROFILES_USERS,
USERNAME,
VALIDATEUR,
VALIDATEUR_RESTREINT,
QUALIFICATEUR,
GESTIONNAIRE
FROM $(vFolderQvd)PROFILES_USERS_FINALE.qvd(qvd);

 

View solution in original post

2 Replies
Judicael
Partner - Contributor III
Partner - Contributor III
Author

When I test the login USER only the system account (admin) is granted with the configuration table not users.

Vegar
MVP
MVP

Try to run the script below in a separate application. It's your original script without the section access activated. Add a couple of list boxes, one per table. Click on the different NTNAMES fields to figure out what's happening.

//SECTION ACCESS;

SECTION_ACCESS_USERS:
LOAD
ACCESS,
UPPER(NTNAME) AS NTNAME,
PROCESS_REDUCTION,
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

//SECTION APPLICATION;

LINK_PROFILE_USERS:
LOAD
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES,
PROFILES_USERS_QUALIFICATION
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

 

LOAD
PROFILES_USERS_QUALIFICATION,
PROFILES_USERS,
USERNAME,
VALIDATEUR,
VALIDATEUR_RESTREINT,
QUALIFICATEUR,
GESTIONNAIRE
FROM $(vFolderQvd)PROFILES_USERS_FINALE.qvd(qvd);