Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor II
Contributor II

How to include data where amount of sales is zero or null?

Hi Guys!

I am new to QlikView. I've noticed that using Pivot Table, data with null/zero values are not displayed. If I checked the Suppress Zero Values in the presentation tab, it appears that it ignores the filter in the set analysis just to display the record with null values.  

Example

IdNameMonthYearAmount
XJohn Doe5202010000
YJohn Doe Jr.52020Null
ZJohn Doe III5202020000
XXJoana Doe 5202030000
YYJustin Doe5202040000

 

Using Pivot Table sheet object, John Doe Jr. is excluded in the display. 

What Am I missing guys?

BR, jess

1 Solution

Accepted Solutions
Highlighted
Contributor II
Contributor II

Hi Guys,

If you encounter issue of this kind, here is what I did to resolve it.

1. Make sure that the SalesAmount in expression is not null in the dataset.

2. In the set analysis express add [SalesAmount] = {"<>0"} as an added filter.  

3. Uncheck the Suppress zero-value in the presentation tab.

4. If  you don't do no. 2, doing no. 3 will blow your presentation as it ignores other filters.

I don't know if this behavior is by design or a bug but I am expecting that qlik should display all data for as long as within the scope of the filter without the workaround. I consider the steps as a workaround.

BR, jess

View solution in original post

3 Replies
Highlighted

For me this is Straight table not pivot? What column you are transposing to Row?

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Highlighted
Contributor II
Contributor II

Hi, The info I gave is just a simple table but the context of the problem is the same. We are using Pivot Table because that's the right sheet object we should be using. The amount is the fact expression, the rest are dimensions.

Highlighted
Contributor II
Contributor II

Hi Guys,

If you encounter issue of this kind, here is what I did to resolve it.

1. Make sure that the SalesAmount in expression is not null in the dataset.

2. In the set analysis express add [SalesAmount] = {"<>0"} as an added filter.  

3. Uncheck the Suppress zero-value in the presentation tab.

4. If  you don't do no. 2, doing no. 3 will blow your presentation as it ignores other filters.

I don't know if this behavior is by design or a bug but I am expecting that qlik should display all data for as long as within the scope of the filter without the workaround. I consider the steps as a workaround.

BR, jess

View solution in original post