Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

The Source Document was not reloaded successfully ....!!!

Hi All,

I have a problem that , when i scheduled a task in QMC The reload had happened properly for 10 Hours ,after that the task has been failed because of the reason "The Source Document was not reloaded successfully ". What is the reason/meaning for this error. and what might be the possible reasons for the task to get failure after loading properly for 10 hrs.

Kindly Suggest.....

Thanks

Sathis

5 Replies
Highlighted
Not applicable

I suggest that you look into the QVW log which should be able to provide more details. (Go to Settings -> Document Properties -> General -> Check Generate Log files)

Highlighted
Creator III
Creator III

Hi, Are you able to find out the solution?

I'm facing the similar issue where my task runs for every 2 hrs but in between it's getting failed.

Any suggestions?

Regards,

Viresh

Highlighted
Digital Support
Digital Support

In addition to what the other poster mentioned regarding generation of the Script/Document log, the full Task log would be most helpful in addition to that as well as information regarding configuration of the task and why type of trigger is in use etc.  If you can attach the Document and Task logs, that should be best first step to try to provide further information, without those, there are too many potential reasons to cover here.  

The Task logs are located by default in: C:\ProgramData\QlikTech\DistributionService\1\Log\Date folder\Taskname folder and timestamp, inside the folder will be Task log for sure and there may also be Distribution Report file as well as Document log.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Creator III
Creator III

Hi Brett, Thanks for the reply.

Please find the attached Task and document log for the same. The document log says CUSTOMERCODE field not found but actually the field is very much available. The previous task got loaded successfully with same query.

Regards,

Viresh

Highlighted
Digital Support
Digital Support

Apologies for the late reply, took a couple weeks vacation and just got back to posts last week and slowly getting through things.  So, regarding the error, I would agree with you, the field not found seems to be a misnomer, the following general script error is likely the actual cause, and those are generally logic related, so it appears something in the query may be misformatted or something. 

The best way of which I can think to try to narrow this down at this point would be to just ensure you can do a straight SQL Select with field list from the source, no where clause either.  If that works, then I would likely add the where clause back to check that, if that works, then add the Load statement back, but my hunch is something in the where clause may be where the actual problem lies here.  I am not very good with the scripting side of things, but at least you can try to further troubleshoot and narrow things down here.  Feel free to post back, hopefully it will not take me as long to get back to you next time.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.