Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

SAP Extractor: Init failed

Hello,

I'm trying to use the QvSAPEXTRConnector to load data from the DataSource 0HR_PT_1. It works on RSA3.

On QlikView, the script runs a very long time and finaly I have this error:

Init failed

SQL EXTRACTOR 0HR_PT_1

UPDMODE F  

     

EXTRLANGUAGE F

LOGSYS QTQVCEXTRB

I use the update mode full:

[0HR_PT_1]:

LOAD

  [COMP_CODE_WP],

  [KDAY],

  [KMONTH],

  [PERNR],

  [PLHRS],

  [UNIT];

SQL EXTRACTOR 0HR_PT_1

UPDMODE F   // full extractor

//UPDMODE C   // initial extraction, to be followed by delta extractions

//UPDMODE D   // delta extraction

//INITRNR <NR>  // Resend extraction

EXTRLANGUAGE F

LOGSYS QTQVCEXTRB

;

STORE * FROM [0HR_PT_1] INTO FULL_0HR_PT_1.QVD;

DROP TABLE [0HR_PT_1];

I need to start a init load???

Thanks for any help.

7 Replies
adnan_rafiq
Partner - Creator II
Partner - Creator II

Mishel

I am facing same issue. did you resolve it.

I was able to fetch data previously. but suddenly it gave this error and now it giving same error on every DataSource.

Regards

Not applicable
Author

Actually, I have not found the solution.

adnan_rafiq
Partner - Creator II
Partner - Creator II

That's bad. Let me know if you came across any update on this. I will update if i find any thing.

Regards

suniljain
Master
Master

Can you check log in SAP for the user id that you are using for data extraction?.

adnan_rafiq
Partner - Creator II
Partner - Creator II

Hi Sunail,

I have been able to extract data just a day ago. I refreshed it couple of times. but suddenly it started giving me this error and there is no releif now.

Regards

adnan_rafiq
Partner - Creator II
Partner - Creator II

Hi ,

There seems seems to be some problem in the client on SAP. I do the same transport on a different client of same environment and its still working fine so far. Make sure you are following all the steps mentioned in SAP Connector manual far SAPEXTRA Connector.

Regards

Not applicable
Author

Hello,

I found the problem: I have two logical system in SAP for QlikView and only one works.

My error: I tested with the incorrect logical system.

Thanks and Regards.