Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

How to Enable all macros

Hello,

Well, i have a QlikView Document that contains macros ( Button for exporting to excel). Everything works, I have deployed the application in the server. And when users Log into Qlikview  for the first time a window appear ( please see the screenshot attached) that contains three choices :

- Désactiver les macros (Disable Macros)

- Activer les macros sûres (Enable secure macros)

- Activer toutes les macros (Enable all macros)

Users should select " Activer toutes les macros (Enable all macros)" so that the Export button works , but some of them choose "Activer les macros sûres (Enable secure macros)" and the macros doesn't work and  the system remember that choice.


How can I get back to that window so that i can change the selected choice ?????

QLIKVIEW.png

Thank you

1 Solution

Accepted Solutions

Re: How to Enable all macros

If the users press ctrl+shift+M this dialog appears again. Another approach would be to edit the settings.ini from each user.

- Marcus

6 Replies
Employee
Employee

Re: How to Enable all macros

Please post only once : how to Enable all macros

Re: How to Enable all macros

If the users press ctrl+shift+M this dialog appears again. Another approach would be to edit the settings.ini from each user.

- Marcus

trdandamudi
Honored Contributor

Re: How to Enable all macros

Open the QlikView client, and go to Help and click on "About QlikView" and then right-click the QV icon in the lower left corner to bring up the Settings dialog, and scroll until you see the setting "macrolaunchconfirmation", and change the value to 1 from 0 and click the Set button and then exit out.


Hope this helps:

Not applicable

Re: How to Enable all macros

thank you for your response, I have 1 as value in "macrolaunchconfirmation" Not 0

Not applicable

Re: How to Enable all macros

thank you for your response.

Please where can I find ettings.ini and what should I edit ??

Re: How to Enable all macros

You find the settings.ini in this path:

C:\Users\YourUserName\AppData\Roaming\QlikTech\QlikView

- Marcus