Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

scott_brown
New Contributor III

Qlikview Performance Issue

We have been experiencing intermittent performance issues with documents taking much longer to load and respond than normal, our solution has been to restart the services which seems to fix it. There doesnt appear to be anything specific that causes it, but it has been happening once a week or so. The attached screenshot is of the QVS statistics tab in the QMC while we were having issues, any thoughts?

2 Replies

Re: Qlikview Performance Issue

Those stats provided by the QMC are point-in-time, to understand an excessive consumption from Qlik we would need to see at least a day worth of data and probably more.

To better understand the issue, is QlikView slower in any particular action like opening the document, or reloading data, or it is just slower in general, browsing and clicking around without any relevant increase in complexity or data in that same application?

If you recently upgraded from QlikView 11.x to QlikView 12.y this could be one explanation, as 12 is more resource intensive, especially in the reloads. Also, according to the screenshot, it looks like it's running QlikView 12 IR, upgrading to a more recent one could be a good idea, if possible.

I would suggest that you take the QlikView Governance Dashboard, which can be obtained from the Qlik Software Download site, and if the issue can be narrowed down to one or a few applications, check them in more detail with both the Governance Dashboard and the Document Analyzer by Rob Wunderlich.

If it is not related to the usability of the application but to the loading time, try to see which part of the script is taking longer. The application log will tell you that. You can enable it opening the QVW with Desktop > Settings > Document Properties > General > Generate logfile.

If it happens mostly when the user opens the application, check the configuration of the DSC if there have been changes in domains, DNS, group membership or similar.

MVP & Luminary
MVP & Luminary

Re: Qlikview Performance Issue

Based on the data you posted and the weekly occurrence my assessment is that you are running low on RAM when you see these slowdowns.  Your VMcommited is way over your actual RAM of 62GB. Restarting the services releases the RAM and gives you a fresh start but over a period of a week you find yourself full again.

You can double check that RAM is an issue with a couple of tools.

1. The Governance Dashboard will show you RAM usage over time.

2. The QVS Event_*.log files will contain messages like:

"WorkingSet: Virtual Memory is growing beyond parameters - nnn GB".  I'll bet you'll see a lot of those

To address a RAM issue you can either increase the RAM or decrease the RAM requirement.

RAM is fairly inexpensive these days so throwing some hardware at the problem is often the fastest & cheapest fix.

Tips for reducing RAM requirements:

1. Reduce the Document Timeout value in the QMC to allow documents to be unloaded sooner.

2. Reduce the "Maximum Inactive Session Time" value in the QMC to allow users to timeout earlier.

3. Tune the QVWs to use less RAM.

I think #1 & 2 would give limited relief in your case, but they may be worth a try.

This is a best guess based on my limited view of your situation.  If you want a more refined analysis of your problem or some support in remediating it, feel free to reach out to me in a PM or Contact | Qlikview Cookbook

-Rob

http://masterssummit.com

http://qlikviewcookbook.com

http://www.easyqlik.com