Qlik Community

Ask a Question

QlikView Integrations

Discussion Board for collaboration on QlikView Integration.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Google Maps Integration Gone? Anyone else?

Is anyone else having trouble with the Google Maps layer disappearing from existing Qlikview applications?  As of today nothing on either desktop or server-hosted Qlikview has a Google map in the background.

We're running Qlikview 11.

I tested the Qlikview-generated URL, which is

http://maps.google.com/staticmap?center=38.097986,-106.0454515&zoom=2&maptype=&size=800x300&key=xx&....

It generates a 403 error with the following documentation:

This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage.

For more information about HTTP errors, see Help

1 Solution

Accepted Solutions
Not applicable
Author

Hi noahshlaes,

Google Map API v2 has been deprecated, try with this URL:

http://maps.googleapis.com/maps/api/staticmap?center=38.097986,-106.0454515&zoom=2&maptype=&size=800...

but you should replace the key 'xx' with a real one, otherwise it doesn't work.

Giada


View solution in original post

35 Replies
Nicole-Smith

Ours are missing too...  I wonder what's going on.

julian_rodriguez

Same here!

Brian_Munz
Specialist
Specialist

I know they're turning off v2 of the google maps API soon.  Maybe it has something to do with that?  DO you know which version of the API you're running?

https://developers.google.com/maps/documentation/javascript/v2/

julian_rodriguez

As Brian says, it should be related with the API version,

The error message is clear "This web site needs a different Google Maps API key. A new key can be generated at http://code.google.com/apis/maps/"

May be you should read about this on the API website: https://developers.google.com/maps/documentation/javascript/tutorial?hl=en#api_key

I have the same issue, so let me check what is the resolution for this...

Not applicable
Author

Hi noahshlaes,

Google Map API v2 has been deprecated, try with this URL:

http://maps.googleapis.com/maps/api/staticmap?center=38.097986,-106.0454515&zoom=2&maptype=&size=800...

but you should replace the key 'xx' with a real one, otherwise it doesn't work.

Giada


View solution in original post

julian_rodriguez

The URL posted by Giada works fine.

Thanks so much!

Not applicable
Author

Resolved - thanks! 

Not applicable
Author

Hi all,

I have the same problem for two days, and I have made the change posted by giada.

Now it's working my google map is reup, but all my points are not at the good place.

I change only the dynamic pictures like this:

='http://maps.googleapis.com/maps/api/staticmap?'

&

num(var_mid_lat, '##############', '.', ',' )

&

','

&

num(var_mid_long, '##############', '.', ',' )

&

'&zoom=$(var_zoom)'

&

'&maptype='&var_maptype

&

'&size='&map_size_x&'x'&map_size_y

&

'&key='&gmap_key

&

'&sensor=false'

&

'&scale='&map_scale

But now all my points are not correctly placed (normaly all points are in Europe) Do you have an idea? On the old map all was correct

Sans titre 1.jpg

Thanks in advance

Not applicable
Author

Hi Bati,

I think you forgot the "center" keywork in the URL, try this:

='http://maps.googleapis.com/maps/api/staticmap?center='

&

num(var_mid_lat, '##############', '.', ',' )

&

','

&

num(var_mid_long, '##############', '.', ',' )

&

'&zoom=$(var_zoom)'

&

'&maptype='&var_maptype

&

'&size='&map_size_x&'x'&map_size_y

&

'&key='&gmap_key

&

'&sensor=false'

&

'&scale='&map_scale