Qlik Community

QlikView Integrations

Discussion Board for collaboration on QlikView Integration.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
vindhya_giri
Creator II
Creator II

Help with SVG maps show and hide functionality

Hi,

I am trying to use QlikView extension: SVG maps.

I was successfully able to create one as per the requirement but having an issue with the show and hide functionality.

Behavior:

When I create a map in a new sheet. It works as expected and as per the selections in other objects in the dashboard.

But when I created a button in one of the sheets( there are few more buttons available in the same sheet) in the dashboard and put a condition in the options of the SVG map to be visible only when this particular button is selected. I am able to view the map when that particular button is selected but only issue is that the selections from other objects in the dashboard are not reflecting in the map.

Example: I select a region 'Northeast' in a list box, it is not reflecting in the map. I am still able to see the whole USA map. But when I turn off the web view and turn it on back, I see that the Northeast region is selected. So every time, I have to turn off and turn on the web view to see the correct selections.

Please advise

Thanks

Regards

Vindhya

5 Replies
MK9885
Master II
Master II

Can you upload the test qvw?

vindhya_giri
Creator II
Creator II
Author

Hi Shahbaz,

I do not have a test qvw as of now.

On further testing,I figured that irrespective of the SVG map being in a new sheet or a button is not making any difference. The only issue is that the selection in any other list box or any other object in the dashboard is not reflecting in the map. In desktop when I turn off and turn on the webview, I see the results correctly. And in AccessPoint, when I refresh the page with 'Reload this page' sign beside the URL, I see the correct results. Not able to figure out why is this happening.

Thanks

Regards

Vindhya

MK9885
Master II
Master II

Hi,

That's really odd behavior. Maybe try reinstalling the SVG extension, cus it might be an older version?

Below is the updated SVG Map, Just unzip the folder, copy paste in your extension folder and try it. I've also used conditional expression in my svg and it works fine.

In fact I used 3 maps, overlaying upon each other and upon selection each map disappears and only show selected regional map.

Updated SVG Map files (US State Names)

vindhya_giri
Creator II
Creator II
Author

I tried to use SVG map in a different qvw for testing and is working fine (no need to turn on or turn off the web view). For some reason, it is not working only in this particular app. I tried to change the color coding and expression but nothing helped. Surprisingly, it is only in this particular app where I have to turn off and turn on the web view or refresh the page to see the correct results.

MK9885
Master II
Master II

I believe it might be the issue with the qvw. If it is not too much of designing then maybe you should try developing a new qvw file or delete that SVG sheet, make a new one?

SVG is pretty basic map and doesn;t require much of the memory, I do not know why it is behaving oddly.

Apart from this I don't see any other solution to this, unless I get hands on your sample data to check it (if it's not confidential).

Thanks.