Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

duncan_andrew8
New Contributor II

AccessPoint Export to CSV with commas

Hi everyone,

We've recently upgraded our QlikView Server from 11.2 to 12.1 SR7. (Fresh install)

It seems as though the AccessPoint's exporting functionality might have gone a bit backwards, we've noticed that the limit to export to Excel is now about 1m cells. Anything larger than this will be automatically converted to a CSV.

On top of this, the CSV seems to now be semicolon delimited whereas it was comma delimited before. This is strange as I've found a few other thread asking for help to switch from commas to semicolon - in Germany apparently the standard is for semicolons.

This has understandably caused a bit of confusion with our users - if the file is opened from file explorer, Excel opens it with its automatic CSV-reader settings (where it expects the delimiters to be commas).

Does anyone know how to change the AccessPoint's export to CSV functionality to delimit using commas?

Thanks in advance!

1 Solution

Accepted Solutions
duncan_andrew8
New Contributor II

Re: AccessPoint Export to CSV with commas

In case anyone stumbles across this in the future - we finally managed to find a solution to this.

This issue was being caused by the Regional Settings on our server (Windows Server 2012 R2). For some reason with the fresh install it set the decimal symbol as a ',' (comma) and the list separator as a ';' (semi-colon).

Can be changed as follows:

On the server, go to Regional Settings - from the start page, type 'region'.

Click on 'Additional settings...'

Region Settings.jpg

In the following window, change the fields to your required settings:

Region Settings advanced.jpg

It might also be an idea to change the Currency settings in the relevant tab.

If this doesn't work - which ours didn't - settings can be changed in the registry:

Registry.jpg

Note that above is changing for the default user - it might be necessary to change the registry settings for other users on the server - most importantly the user which runs the QlikView services.

Best of luck!

4 Replies
imanekhoma
New Contributor

Re: AccessPoint Export to CSV with commas

hello,

I am facing same issue i store data in a CSV but file doesn't accept the semicolon as a delimiter, when i put a comm it works

If you have any Ideas

Thank in Advance

duncan_andrew8
New Contributor II

Re: AccessPoint Export to CSV with commas

In case anyone stumbles across this in the future - we finally managed to find a solution to this.

This issue was being caused by the Regional Settings on our server (Windows Server 2012 R2). For some reason with the fresh install it set the decimal symbol as a ',' (comma) and the list separator as a ';' (semi-colon).

Can be changed as follows:

On the server, go to Regional Settings - from the start page, type 'region'.

Click on 'Additional settings...'

Region Settings.jpg

In the following window, change the fields to your required settings:

Region Settings advanced.jpg

It might also be an idea to change the Currency settings in the relevant tab.

If this doesn't work - which ours didn't - settings can be changed in the registry:

Registry.jpg

Note that above is changing for the default user - it might be necessary to change the registry settings for other users on the server - most importantly the user which runs the QlikView services.

Best of luck!

duncan_andrew8
New Contributor II

Re: AccessPoint Export to CSV with commas

Hi imane,

Not sure if I understand correctly - your problem seems to be storing as a CSV in the load script?

imanekhoma
New Contributor

Re: AccessPoint Export to CSV with commas

Hello,

Thankyou for te responce my problem was resolved.

Imane

Community Browser