Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

ODBC connection issue while connecting to Oracle database

Hi,

I am connecting to Oracle database server (11g) from QlikView 9.0 using ODBC connection. I have around 10 tables from which i am getting data into QlikView. The size of data is around 10 mb. When i start the reload, the connection is established to Oracle Server and data loading starts, but after loading 3-4 tables the loading stucks in between and does not complete. I disabled the antivirus and tried but still no luck. Sometimes the load completes successfully, but most of the time it stucks after loading few tables. Is this a issue with QlikView ? Please let me know if anyone faced such issue and possible resolution.

Thanks,

Samir

3 Replies
Luminary
Luminary

ODBC connection issue while connecting to Oracle database

I am experiencing similar things when retrieving large amounts of information (tens of millions of rows) accessing a PostgreSQL database, with queries taking +5 mins to complete.

I never found a solution, my best guess is that we are looking at a timeout issue either in QlikView or in the ODBC drivers themselves.

My workaround is to incrementally load data from the SQL database, in my case I am loading data for one month at a time into QlikView, looping over all months for which there is data. Works fine, even though you'll have to write some extra script code to set it up.

/Göran

Not applicable

Re: ODBC connection issue while connecting to Oracle database

Hi

When experiencing this problem do either of you see Qlikview return a success response on the reload but then discover that only a partial dataset was loaded.  We have seen this happen three times now over 10 weeks. 

QV says the script has reloaded successfully but when we look at the loaded data some of it is missing.  If the script is executed again it returns the full dataset.  This is a major concern for us because we need to rely on the scripts loading all the data all of the time.  If there is a problem it should error not say it was successful.  Alarmingly we are talking about relatively small datasets (e.g. 120,000).

For now we are monitoring the datasets each day for obvious discrepencies, so it's far from ideal.

Our data source is Oracle 11gR2, connecting with 64 BIT ODBC drivers.

Thanks

Andrew

Not applicable

Re: ODBC connection issue while connecting to Oracle database

Regarding the partial dataset problem I posted about.  QlikTech have finally recognised this as a fault and are working on a fix.  See my posts on this separate thread - http://community.qlik.com/message/215900?tstart=0#215900