Qlik Community

Scalability

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Jmeter error code

Hi

I'm getting this code in the Jmeterl log when trying to run a test.

0,0,,Non HTTP response code: java.lang.NullPointerException,Non HTTP response message: null,QlikView 1-1,text,false,991,1,1,0

Here is the path to the document

http://ait-pqv-webp4/QvAJAXZfc/opendoc.htm?document=ef%5Cefecte.qvw&host=ait-pqv-webp4

Here is the variables from the script.

I'm using NTLM, JAVA 64 bit, jMeter 3.2, QV12.1

I'm also getting this error

2017-06-12 15:29:42,022 WARN o.a.j.p.h.c.HC4CookieHandler: Not storing invalid cookie: <LoginWIN%5cadm-aaak=True; expires=Tue, 12 Jun 2018 13:29:41 GMT; HTTPOnly> for URL http://ait-pqv-webp4/QvAJAXZfc/AccessPoint.aspx?mark=&platform=browser.gecko.3.6&dpi=96 (Cookie name may not contain blanks)

2017-06-12 15:29:42,022 WARN o.a.j.p.h.c.HC4CookieHandler: Not storing invalid cookie: <WelcomeNameWIN%5cadm-aaak=Ali+Akbar+Khalaj+(AIT-ITAdm); expires=Tue, 12 Jun 2018 13:29:42 GMT; HTTPOnly> for URL http://ait-pqv-webp4/QvAJAXZfc/AccessPoint.aspx?mark=&platform=browser.gecko.3.6&dpi=96 (Cookie name may not contain blanks)

1 Solution

Accepted Solutions
Daniel_Larsson
Employee
Employee

Hi,

We have seen problems when using JMeter 3.2, could you please first try using an earlier version? If there's still a problem when can go from there.

From Tools page:

PLEASE NOTE:

We got some reports about problems with QVScalabilityTools and QlikView Hardware Benchmarking test when used with JMeter 3.2. Due to this we suggest to use JMeter 3.0 which can be downloaded from here: https://archive.apache.org/dist/jmeter/binaries/apache-jmeter-3.0.zip

We're investigating this issue.

View solution in original post

3 Replies
Daniel_Larsson
Employee
Employee

Hi,

We have seen problems when using JMeter 3.2, could you please first try using an earlier version? If there's still a problem when can go from there.

From Tools page:

PLEASE NOTE:

We got some reports about problems with QVScalabilityTools and QlikView Hardware Benchmarking test when used with JMeter 3.2. Due to this we suggest to use JMeter 3.0 which can be downloaded from here: https://archive.apache.org/dist/jmeter/binaries/apache-jmeter-3.0.zip

We're investigating this issue.

Not applicable
Author

THANKS!!

That solved the issue!

Kritika
Contributor
Contributor

Hi @Daniel_Larsson,

We have tried using JMeter 5.3, 4.0, and 3.0.

With the 5.0 and 4.3 versions, we are getting the Not storing invalid cookie: error.

However, when we used 3.0 the preload test is failing with 11 errors, and no errors are being written in the log file which has become difficult for us to debug.

Can you please help us and let us know if we need to enable or change some other settings or try another version?