4 Replies Latest reply: Feb 19, 2014 9:58 AM by Oscar Marquez RSS

    Section Access question

    Oscar Marquez



      I'm using data reduction based in 1 field (Region). I've found in multiple pages, that in order to allow user to see everything, you either leave the field blank or you can type <ANY>.


      In desktop either way works fine, but once in the access point it will say "You don't have access to this document" unless I specifically type 3 times (one per region) for every user with WW privileges.


      Is this supposed to be like that or I'm doing something wrong?



      Working in desktop but not in web:





      Working in desktop and web:



      Thanks in advance!

        • Re: Section Access question
          Carlos Reyes



          Did you enabled the "Strict Exclusion" checkbox in the Document Properties? If so then you can't place a null value in the filter field. It'll work in the Desktop but never in server since in the AccessPoint all users (even ADMIN) are treated as users. So, if you enable "Strict Exclusion" you always have to create all the valid records for any user so it's able to enter the application.


          The "Strict Exclusion" option checks that records in the Section Access table are valid for the data model and if it's not, then the user will be unnable to enter the app. If you don't enable the "Strict Exclusion" option, then if a user doesn't have a valid Section Access record, QlikView will enable that user to enter the app and see all the data in it.


          About the "ANY" value used in several examples in the Community... As far as I know...I think it's meant to indicate that that value will be used to generate all the valid records for that user, usually using applymap and other functions, because "ANY" is not a reserved value that QlikView will recognize as all the possible values. So, QlikView will try to match "ANY" to a posible REGION (in your case) and that will never be found so the user won't be able to enter the app.


          Hope this helps!