12 Replies Latest reply: May 11, 2014 10:11 PM by ano milo RSS

    QVS Services stopping several times a day

      Dear All,

       

      I'm using qlikview for a few years, right now I have a little problem with my Qlikview Server.

      For sometimes my QVS services stopping accidentally for any reason.

      I'm looking for at all logs file but have no clues, then I look at Event Viewer in Windows Server it tell's something like this :

       

      Application: QVWebServer.exe

      Framework Version: v4.0.30319

      Description: The process was terminated due to an unhandled exception.

      Exception Info: System.ApplicationException

      Stack:

         at System.Net.HttpListener.BeginGetContext(System.AsyncCallback, System.Object)

         at QlikView.AccessPoint.HttpServiceComponent.HandleRequest(System.IAsyncResult)

         at System.Net.LazyAsyncResult.Complete(IntPtr)

         at System.Net.ListenerAsyncResult.IOCompleted(System.Net.ListenerAsyncResult, UInt32, UInt32)

         at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

         at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

         at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)

       

      Then I saw all services stopping 1 by 1, so I have to start it again.

      I'm using QVS 64bit 11.2 .11643 with Windows Server 2008 R2.

      Anyone have an idea to solving this?

       

      Regards,

      Effendi

        • Re: QVS Services stopping several times a day
          Prem Kumar Thangallapally

          is your server password has been changed?

          or see performance in task manager is it getting increased ?

          or see if applications size has been increased ?

          • Re: QVS Services stopping several times a day

            Since you're on the initial release of 11.20, I would first look at upgrading to a later version. That would also give you the benefit of essentially repairing the QVWS. Also, even though the possibility is remote, I would do a hardware check to make sure none of your disks are having issues.

            • Re: QVS Services stopping several times a day
              Sudeep Mahapatra

              Are you using QV webserver alone or with IIS support?

              You may check the Web server setup. I would recommend contacting Qlik Support for any known issue and patch info.

              • Re: QVS Services stopping several times a day

                hello everyone, the error just raise again just a moment, i copied some eror log that i need to know what it's mean..

                first this come from exit.log file :

                2014-05-06 03:45:00: Spawning KillerThread

                2014-05-06 03:45:00: KillerThread calling ServerExit

                2014-05-06 03:45:00: ServerExit entered

                2014-05-06 03:45:00: Kill child processes still running

                2014-05-06 03:45:00: Calling pListener->Close

                2014-05-06 03:45:00: Calling CQvMiniHttpsService->Stop

                2014-05-06 03:45:00: Calling pACLCache->Close

                2014-05-06 03:45:00: Calling pClusterMonitor->Close

                2014-05-06 03:40:57: Calling pMetaScheduler->Close

                2014-05-06 03:40:58: Calling pPurger->Close

                2014-05-06 03:40:59: Calling pGDIPlusChecker->Close

                2014-05-06 03:40:59: Calling pLogWriter->Close

                2014-05-06 03:40:59: Calling pPgoSync->Close

                2014-05-06 03:41:00: Calling ExitThreadWorkerThreads

                2014-05-06 03:41:00: Calling ProtExit

                2014-05-06 03:41:00: ProtExit entered

                2014-05-06 03:41:00: Calling StopSocketMgr

                2014-05-06 03:41:00: Calling ExitHttpTunneling

                2014-05-06 03:41:00: Deleter is running

                2014-05-06 03:41:00: Waiting

                2014-05-06 03:41:00: Done

                2014-05-06 03:41:00: 0 residual threads

                2014-05-06 03:41:00: Calling ExitGdiPlus

                2014-05-06 03:41:00: ExitGdiPlus done

                2014-05-06 03:41:00: ServerExit done

                2014-05-06 03:41:00: Terminating service

                2014-05-06 03:41:00: Stopping Cache Trimmer2014-05-06 03:41:00: ExitInstance entered

                2014-05-06 03:41:00: Cache Trimmer stopped

                2014-05-06 03:41:02: ExitInstance calling base class

                2014-05-06 03:41:02: ExitInstance done

                 

                Second, coming from event viewer in windows, this information always show up all the time, i don't know it's an eror or what:

                The description for Event ID 700 from source QlikViewServer cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

                 

                If the event originated on another computer, the display information had to be saved with the event.

                 

                The following information was included with the event:

                 

                Mount: Browsing D:\QVW_DASHBOARD\. User=QLIKVIEWSVR\Administrator, ImpLev=0

                 

                 

                Thx a lot

                  • Re: QVS Services stopping several times a day
                    Peter Cammaert

                    In one of the other (very old) threads that you tried to reanimate with this problem, I read that you're running two QVS's in the same network segment. Are you really sure that that they were licensed with different license codes?

                     

                    If so, then what do you find at the end of the Events log of the QVS that is unexpectedly shutting down? Please post the part immediately before the Exit log is generated.

                      • Re: QVS Services stopping several times a day

                        Hi Peter,

                        yes correct, i'm using 2 QVS's with different license, but only 1 QVS that has problem like this.

                        I post the events log from QVS just right when services stopping,

                        2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: CNTService::Handler(1)

                        2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: CNTService::SetStatus(4151376, 3)

                        2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: CNTService::OnStop()

                        2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: Updating status (4151376, 3)

                        2014-05-07 14:10:43    2014-05-07 21:06:48    4    700    Information    Debug: Done Running

                        2014-05-07 14:10:43    2014-05-07 21:06:50    4    700    Information    Document PreLoad: Stop

                        2014-05-07 14:10:43    2014-05-07 21:06:51    4    700    Information    DOC loading: Unloading document D:\QLIKVIEWPUBLISHER\REPORT\LAP_SALESHARIANPERTOKO_TEST.QVW, state UNLOADING.

                        2014-05-07 14:10:43    2014-05-07 21:06:51    4    700    Information    DOC loading: Unloading document D:\QVW_DASHBOARD_REVISI\DASHBOARD_TEST.QVW, state UNLOADING.

                        2014-05-07 14:10:43    2014-05-07 21:06:55    4    700    Information    Debug: CNTService::SetStatus(4151376, 1)

                        2014-05-07 14:10:43    2014-05-07 21:06:55    4    700    Information    Debug: Leaving CNTService::ServiceMain()

                        2014-05-07 21:06:57    2014-05-07 21:06:58    4    700    Information    NUMA: NUMA nodes enabled

                        2014-05-07 21:06:57    2014-05-07 21:06:58    4    700    Information    WorkingSet: Configured Working Set Size is 358.391-460.788 GB (setting 70%-90%)

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: Calling StartServiceCtrlDispatcher()

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: Entering CNTService::ServiceMain()

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: CNTService::SetStatus(3627088, 2)

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Debug: CNTService::SetStatus(3627088, 4)

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    PGO: Creating file IniData.pgo

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount  at location D:\QVW_Default  browsable

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount IDMMonitoring at location D:\QVW_Monitoring  browsable

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount Dashboard at location D:\QVW_DashBoard  browsable

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount Dashboard_revisi at location D:\QVW_Dashboard_revisi  browsable

                        2014-05-07 21:06:57    2014-05-07 21:06:59    4    700    Information    Mount: Found Mount QlikviewPublisher at location D:\QlikviewPublisher not browsable

                        2014-05-07 21:06:57    2014-05-07 21:07:00    4    700    Information    Document PreLoad: Start

                        2014-05-07 21:06:57    2014-05-07 21:07:01    4    700    Information    Debug: CNTService::Handler(4)

                        2014-05-07 21:06:57    2014-05-07 21:07:01    4    700    Information    Debug: CNTService::OnInterrogate()

                        2014-05-07 21:06:57    2014-05-07 21:07:01    4    700    Information    Debug: Updating status (3627088, 4)

                        2014-05-07 21:06:57    2014-05-07 21:07:11    4    700    Information    Mount: Browsing D:\QVW_DEFAULT\. User=QLIKVIEWSVR\Administrator, ImpLev=0

                         

                        Mostly I read from many threads in community has this logs, but no one can answer or solve.

                        I need to find a reason and telling to my boss before I formatting all my server.

                         

                        Is there some experiences that failed reload schedule can turning off all services?

                        I already set the NUMA setting also in settings.ini as I found the thread here, but still cannot fix this.

                        I disable all reload schedule yesterday, and still happen last night twice.

                        All the logs file I learn nothing tells more about the stopping services, it just 'boom', the services said 'I want to stop, I'm tired'

                        Please tell me if there is another log files you need.

                         

                        PS: I have already upgraded into QVS 11.2.12235 version

                         

                        Thx

                    • Re: QVS Services stopping several times a day

                      I have something to share, that interesting for me.

                      My QVS server using Windows Server 2008 R2.

                      Since this is the first time I met this problem, I learn all logs file to find the solution

                      Below I send an image of my windows events viewer :

                      As seen, in my post reply to Peter, I put the log that said the QVS stopping at 21:06:47

                      2014-05-07 14:10:43    2014-05-07 21:06:47    4    700    Information    Debug: CNTService::Handler(1)

                      and when I check in security events viewer, 1 process just before qvs services stop, that called RHS.EXE as it seen starting at a few seconds earlier 21:06:41, and when I check the events for last a week, it always happen just before my qvs problem.

                      I try to figure it out what RHS was, and it said Resource Host Subsystem, in technically really confusing for me to learn.

                      So if someone can teach what is that RHS, and what can cause problem with QVS, it would be helpful.

                      Or can we just shut RHS down, how?

                      Thx

                      • Re: QVS Services stopping several times a day

                        hi, for update at the moment,

                        I have take a look between two servers I have, which one server have no Failover Cluster feature, and the one has it.

                        So I assume this Failover Cluster feature on Server Configuration is the cause problem.

                        I will check with my IT infrastructure to talk about this.

                        I'll be back later for more info.

                         

                        Thx

                        • Re: QVS Services stopping several times a day

                          Dear all,

                           

                          I will close this thread as answered, since my QVS problem is on Cluster setting in Windows Server.

                          Actually my cluster server was unuse anymore, but the setting in Server still existing, so that the cause of QVS stopping all services.

                          I hope for anyone have similar problem have an option to check your cluster setting, if exists.

                           

                          Thanks everybody have a good day..