1 Reply Latest reply: Oct 26, 2015 10:18 AM by Christoph Hebig RSS

    Map Visualisation, custom Mapbox Link

    Christoph Hebig

      Hi Community,

       

      I (still) have the problem that i can't use my own mapbox map link. I got 2 of them:

       

      1. https://a.tiles.mapbox.com/v4/chebig.noj8p17j/page.html?access_token=pk.eyJ1IjoiY2hlYmlnIiwiYSI6ImNpZzBwOXY0bzAwMWl2cGx3MGdiYXFhOWQifQ.frSHb6az2z8rw3B9HzZXSw#2/3.3/-22.9

      This one opened up in the browser works well, but pasted in Qlik Sense (of course i use the ${z}/${x}/${y} properties in Qlik), it gives me

      no map neither an error message.

      When i replace 2/3.3/-22.9 with "${z}/${x}/${y}.png" at the end i get the same. I also tried v3 instead of v4, then i get error 401 unauthorized.

       

       

      2. https://a.tiles.mapbox.com/v4/chebig.noj8p17j/${z}/${x}/${y}.png

      This one (is the one that Mapbox links normally look like for Qlik) isn't working at all, neither in the Browser as link nor in Qlik as Slippy Map URL. In Qlik Sense I get the 401 unauthorized error again, in a Browser I get practically the same but spelled a bit different {"message":"Not Authorized - No Token"}. I also tried v3 instead of v4, but the only Difference is the shorter error version in the Browser {"message":"Unauthorized"}.

       

      To notice:

      -Browser = Chrome (newest one), also tried IE9+

      -Qlik Sense 2.1.1

      -Mapbox free account

      -Map Created with TileMill, exported as .mbtiles, uploaded to mapbox.com and created a new Project out of it there (no complications at all in the process)

       

      I hope that anyone can help me with this, because i think that there is only a little thing i'm missing, but i'm clueless at the moment

       

      Very Thankful in advance!

      Regards

      Chris