7 Replies Latest reply: Jan 13, 2011 1:59 AM by upendra11 RSS

    QlikView 10 Enable IE Plugin Auto Install

      Is there a way to enable the plugin download prompt if a user doesn't have the plugin installed after the user clicks on a link for QlikView 10?

      I've tried to switch to using the opendoc.htm.old file but that doesn't seem to enable the prompt.

      Any help is appreciated. Thanks.

        • QlikView 10 Enable IE Plugin Auto Install
          Miguel Angel Baeyens de Arce

          Hello,

          Check the Enterprise Management Console, System, Setup, QlikView WebServer, click on your server, go to the right pane, Accesspoint, and check "Show Link". This will allow the user to download and install (if proper rights are granted) QlikView Plugin 10.

          In any case, you have the installer available in

           

          C:\Program Files\QlikView\Server\QlikViewClients\QlikViewPlugin


          or its equivalent in Windows 7/2008

          Hope this helps.

            • QlikView 10 Enable IE Plugin Auto Install

              Thanks for the reply, Miguel, but that doesn't quite work for my case since my users are bypassing AccessPoint.

              I am supplying a direct link to the QlikView document for the users to click on (ex. http://server/qvplugin/opendoc.htm?document=app.qvw). I'd like IE to prompt the user to download the plugin if it's not installed after they click on the link.

              I know this is possible in previous versions of QlikView but I am unsure how to implement this in QlikView 10.

                • QlikView 10 Enable IE Plugin Auto Install
                  robins

                  There is a file with the name opendoc_fix.htm available in server.

                  Rename opendoc.htm to something else and make opendoc_fix.htm as opendoc.htm

                    • QlikView 10 Enable IE Plugin Auto Install

                      Unfortunately, this file does not exist under the Server\QlikViewClients\QlikViewPlugin folder in QlikView 10. Instead, there are only "opendoc.htm" and "opendoc.htm.old". The "opendoc.htm.old" file looks like what the "opendoc_fix.htm" does from the descriptions of the other posts but when I use it to load a document, it doesn't seem to work correctly. All it does is show the page is loading and the status bar at the bottom of IE increases at an extremely slow rate even though the machine I tested this on already has the plugin installed. Using the original "opendoc.htm" loads the qvw almost instantaneously.

                        • QlikView 10 Enable IE Plugin Auto Install

                          After further research with the opendoc.htm.old file, we were able to figure out the solution.

                          In order to enable IE to prompt the user to download the plugin if it's not installed, you need to do the following steps:

                          1) Go to "C:\Program Files\QlikView\Server\QlikViewClients\QlikViewPlugin" and rename "opendoc.htm" to something else and rename "opendoc.htm.old" file to "opendoc.htm".

                          2) Open up the new "opendoc.htm" and comment out/remove the clsid object in the html head.

                          If you do not do step 2, IE will be stuck in a page load state that never finishes.

                          Thanks to everyone who viewed/helped.

                  • QlikView 10 Enable IE Plugin Auto Install

                    Hi,

                    Through Access Point you can directly show the link for QVPlugin to dowload and install.