10 Replies Latest reply: Nov 23, 2016 6:19 AM by Daniel Dias RSS

    qlik sense problem

    Ali Hijazi

      Hello

      I downloaded the latest version of Qlik Sense

      I installed it on Windows 2012 server however the management console doesn't open

      the same setup I ran it on Windows server 2008 r2 and the management consoled opened with no problems

      Please advise as the requirement is to install the Qlik sense on windows 2012 server

       

      I got the following error in the proxy log:

      When contacting https://localhost:4242/No connection could be made because the target machine actively refused it 127.0.0.1:4242

       

      Please advise

       

      Message was edited by: Ali Hijazi

        • Re: qlik sense problem
          Andrea Gigliotti

          I have the same issue.

          Is there a way to fix it ?

          • Re: qlik sense problem
            Shraddha Gajare

            What error you are getting on another Server?

            Does IIS is installed on the same Server?

             

            Please check where Port 80,443,4242 are free.

            If some other processes are using these ports then you will need to get it free for Qliksense.

              • Re: qlik sense problem
                Lakshmikandh Karthikeyan

                along with port check if the services are running properly

                • Re: qlik sense problem
                  Andrea Gigliotti

                  No IIS installed

                   

                  The problem seem to be connected with the installation of IBM iSeries ODBC driver for DB2/400.

                  Before Qlik Sense Server was running fine.

                   

                  I uninstalled the program but both hub and qmc still not working .

                   

                  Attached the log files.

                   

                  Somebody can help me to solve the issue ?

                   

                  It's urgent !

                   

                  Thanks in advance.

                   

                  BR

                  Andrea

                    • Re: qlik sense problem
                      Lakshmikandh Karthikeyan

                      is all your Qlik service are running, log files says unable to connect to your repository service ?

                       

                      Try to restart the service manually if thats not working ,restart the server once .

                          • Re: qlik sense problem
                            Daniel Dias

                            Andrea, i have same issue.

                             

                            The link not work from my user.

                             

                            You can help me?

                              • Re: qlik sense problem
                                Lakshmikandh Karthikeyan

                                Raise a ticket in Qlik support,  you will not be able to view that thread mentioned above.

                                • Re: qlik sense problem
                                  Andrea Gigliotti

                                  Daniel,

                                  take a look at this article:

                                  /***

                                  Description

                                  After installing Qlik Sense, the QMC and HUB are not working and result in a "page not found" error.  Review of the Repository logs shows an error, "Fatal exception: Unable to find the requested .Net Framework Data Provider.  It may not be installed." each time the machine is rebooted or the Qlik Sense services are restarted.

                                   

                                  November 2015 update: Version 2.X.X track, new error link to this issue:

                                   

                                  System_Repository logs:

                                   

                                  Unable to determine the provider name for provider factory of type 'Devart.Data.PostgreSql.PgSqlProviderFactory'. Make sure that the ADO.NET provider is installed or registered in the application config.↵↓An exception was thrown while invoking the constructor 'Void .ctor()' on type 'DatabaseContext'. ---> Unable to determine the provider name for provider factory of type 'Devart.Data.PostgreSql.PgSqlProviderFactory'. Make sure that the ADO.NET provider is installed or registered in the application config. (See inner exception for details.)

                                   

                                  Service_Repository logs:

                                   

                                  Error: An exception was thrown while invoking the constructor 'Void .ctor(Qlik.Sense.Logging.IQSLogManager, Repository.Core.INodeStaticInfo, Qlik.Sense.Common.Security.ISecuritySetup, Qlik.Sense.Common.Communication.REST.Server.IRESTEngineFactory, Repository.Core.ISystemInformation, Qlik.Sense.IO.ISystemFolderInformation, Repository.Core.Certificates.ICertificatePasswordVerificationWebService, Qlik.Sense.Common.Logging.ILogMaster)' on type 'SetupService'. ---> The "GetAll" operation failed (See inner exception for details.)

                                  Resolution

                                  This is a Microsoft .NET Framework issue. The .NET Framework creates an extra " <DbProviderFactories />" line under the System.data. Manually delete the extra line.

                                   

                                  To modify the .Net Framework64 to address the issue, perform the following steps in order:

                                   

                                  1- Browse to  "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config
                                  2- Using Notepad or similar editor, open "machine.config" (create a copy of this file prior to modifying)
                                  3- Find the following section :
                                    <system.data>
                                      <DbProviderFactories>
                                        <add name=" .... "
                                     </DbProviderFactories>
                                  <DbProviderFactories />  (If this line is present, REMOVE it as noted in Step 4)
                                    </system.data>

                                   

                                  4- Remove the additional "<DbProviderFactories />" line
                                  5- Save the file.

                                  /***

                                   

                                  It fixed my issue, I hope it will be useful also for you.

                                   

                                  BR

                                  Andrea