3 Replies Latest reply: Jun 28, 2016 12:52 PM by Marc Krichman RSS

    QlikView and  IIS for SSL configuration

    Vindhya Giri

      Hello,

       

      I have read quite a few posts and blogs but did not get a clear understanding of the solution.

       

      Using QlikView 11.2 SR10

      Using IIS 7 as WebServer

      Attached is the document followed for the implementation.

       

      Steps followed:

      1. SSL certificate created

      2. Followed steps in Chapter 3.1 and 3.2 from the attached doc.

      3. Followed the steps in Chapter 5  from the attached doc.

       

      Results:

      QlikView Management  console and Access Point working as expected without any issues.

       

      Issues:

      1. The updated URL for QlikView Distribution Service in QMC is not opening the corresponding XML file.

      2. The updated URL for QlikView Directory Service Connector in QMC is not opening the corresponding XML file.

      3. The updated URL for QlikView Web Servers in QMC is not opening the corresponding XML file.

      When trying to open the updated URL, getting the following error:


      This page can't be displayed". Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to 'updated URL' again. If this error persists, it is possible that this site uses an unsupported protocol or cipher suite such as RC4 (link for the details), which is not considered secure. Please contact your site administrator.


      When looked into the Internet Properties advanced: Use TLS 1.0, 1.1, 1.2 are tick marked


      The attached document said to check if all the services are connected and running (and in my case all the services are connected and running) but did not mention if any error occurred when trying to open the URL.Was not sure if anyone else came across the same scenario. Looking forward for suggestions to resolve the issue.


      Thanks 


      Regard

      Vindhya


        • Re: QlikView and  IIS for SSL configuration
          Marc Krichman

          Vindhya,


          Don't mean to take this post in a different direction but were you able to connect to QMC over port 443 using IIS?


          We have the following configuration and can connect to access point but not QlikView Management  Console:


          Windoiws Server 2012 R2

          IIS8

          Qlikview Server 11.2 SR14


          The document you've attached has slightly different versions and shows how to configure QMC for SSL using Qlikview Webserver but not IIS.


          Thanks,

          Marc

            • Re: QlikView and  IIS for SSL configuration
              Vindhya Giri

              Hi Marc,

               

              Chapter 5 of the document has the steps to make QMC use https URL rather than http.

               

              Chapter 5, Point # 25: https://<FullyQualifiedServerDomainName>:4780/qmc/default.htm

              This is the URL I am able to use. It is still using port 4780 but we have registered all the ports to use https for SSL encrypted communication.

               

              You have AccessPoint URL as https and QMC as http?

               

              Are you using URL rewrite or followed any other steps different from the document attached in the original post?

               

              Thanks

               

              Regards

              Vindhya

                • Re: QlikView and  IIS for SSL configuration
                  Marc Krichman

                  Hi Vindhya,

                   

                  Our configuration requires everything on one server (IIS, Qlikview Server, etc) and all communication to the outside internet use port 443. With Qlikview Access Point already listening on 443 we need a way for QMC to communicate on that port as well. Investigating using multiple IP address and other options with Qlik support.

                   

                  Can you think of a way to do this? We can't find any documentation.